summaryrefslogtreecommitdiff
path: root/libre/linux-libre-tools/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-07-30 19:13:35 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-07-30 19:13:35 -0300
commitaa6c470cb2d9cb7a722d3f99d6fe066281ef1afb (patch)
tree5444e362d9b1afb09a23704045d3a973e75310b9 /libre/linux-libre-tools/PKGBUILD
parent76fae56ff227d0619d84099485c63ba6523c129f (diff)
linux-libre-tools-3.15-1: updating version
Diffstat (limited to 'libre/linux-libre-tools/PKGBUILD')
-rw-r--r--libre/linux-libre-tools/PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/libre/linux-libre-tools/PKGBUILD b/libre/linux-libre-tools/PKGBUILD
index bdeebdb56..de86344ab 100644
--- a/libre/linux-libre-tools/PKGBUILD
+++ b/libre/linux-libre-tools/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 112360 2014-06-01 08:43:39Z fyan $
+# $Id: PKGBUILD 116614 2014-07-30 20:45:24Z seblu $
# Maintainer (Arch): Sébastien Luttringer <seblu@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -14,11 +14,11 @@ pkgname=(
'usbip-libre'
'x86_energy_perf_policy-libre'
)
-_basekernel=3.14
-#_sublevel=3
-#_pkgver=$_basekernel.$_sublevel
+_basekernel=3.15
+_sublevel=7
+_pkgver=$_basekernel.$_sublevel
pkgver=$_basekernel
-pkgrel=3
+pkgrel=1
license=('GPL2')
arch=('i686' 'x86_64' 'mips64el')
url='http://linux-libre.fsfla.org/'
@@ -31,26 +31,28 @@ makedepends+=('perl' 'python2' 'libnewt' 'elfutils' 'libunwind' 'numactl')
# cpupower-libre deps
makedepends+=('pciutils')
# usbip-libre deps
-makedepends+=('glib2' 'sysfsutils')
+makedepends+=('glib2' 'sysfsutils' 'udev')
# tmon-libre deps
makedepends+=('ncurses')
groups=("$pkgbase")
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/$_basekernel-gnu/linux-libre-$_basekernel-gnu.tar.xz"
- #"http://linux-libre.fsfla.org/pub/linux-libre/releases/$_pkgver-gnu/patch-$_basekernel-gnu-$_pkgver-gnu.xz"
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/$_pkgver-gnu/patch-$_basekernel-gnu-$_pkgver-gnu.xz"
'cpupower.default'
'cpupower.systemd'
'cpupower.service'
'usbipd.service'
'01-fix-perf-python.patch'
- '02-parabola-paths.patch')
-sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
- #'561644a6a5d4c434dcd1f1e1dc48c4d8924bfa0407f697b66b7e6de02451acbb'
+ '02-parabola-paths.patch'
+ '03-fix-acpidump-compile-error.patch')
+sha256sums=('93450dc189131b6a4de862f35c5087a58cc7bae1c24caa535d2357cc3301b688'
+ 'ffc3b2c30f38bcdaac32f2236651d1339ef4a9c2a70669938cdc1768440ce5d0'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
'fce128f5e0abfa6916d5cb881456d892d1b163b9639166a4c6c1d53e4dc5086a'
- 'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570')
+ 'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570'
+ 'c791c9eb95e9db28b5a6530232885def9de941d0cbeb9e8b3b999f0567de3199')
prepare() {
cd linux-$pkgver
@@ -61,6 +63,9 @@ prepare() {
fi
patch -N -p1 -i "$srcdir/01-fix-perf-python.patch"
patch -N -p1 -i "$srcdir/02-parabola-paths.patch"
+ # the following patch is a fix for compile error in 3.15
+ # in the 3.16 acpidump code has been reimplemented and patch is not needed.
+ patch -N -p1 -i "$srcdir/03-fix-acpidump-compile-error.patch"
}
build() {
@@ -211,7 +216,7 @@ package_x86_energy_perf_policy-libre() {
package_usbip-libre() {
pkgdesc='An USB device sharing system over IP network'
- depends=('glib2' 'sysfsutils')
+ depends=('glib2' 'sysfsutils' 'libsystemd')
replaces=('usbip')
conflicts=('usbip')
provides=("usbip=$pkgver")