summaryrefslogtreecommitdiff
path: root/libre/linux-libre-tools/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-07 18:29:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-07 18:29:54 -0300
commitaf74ab76fb2b31cf9059b38b4217afc334476252 (patch)
tree35841a424d46a6d4ad290dabaeeb8804534f5fcc /libre/linux-libre-tools/PKGBUILD
parent0fbfc5224d8252c18164bd33fd8773f7ec8bfca9 (diff)
linux-libre-tools-3.16-1: updating version
Diffstat (limited to 'libre/linux-libre-tools/PKGBUILD')
-rw-r--r--libre/linux-libre-tools/PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/libre/linux-libre-tools/PKGBUILD b/libre/linux-libre-tools/PKGBUILD
index de86344ab..5ff82d377 100644
--- a/libre/linux-libre-tools/PKGBUILD
+++ b/libre/linux-libre-tools/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 116614 2014-07-30 20:45:24Z seblu $
+# $Id: PKGBUILD 116876 2014-08-05 00:19:20Z seblu $
# Maintainer (Arch): Sébastien Luttringer <seblu@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -14,9 +14,9 @@ pkgname=(
'usbip-libre'
'x86_energy_perf_policy-libre'
)
-_basekernel=3.15
-_sublevel=7
-_pkgver=$_basekernel.$_sublevel
+_basekernel=3.16
+#_sublevel=7
+#_pkgver=$_basekernel.$_sublevel
pkgver=$_basekernel
pkgrel=1
license=('GPL2')
@@ -36,23 +36,22 @@ makedepends+=('glib2' 'sysfsutils' 'udev')
makedepends+=('ncurses')
groups=("$pkgbase")
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/$_basekernel-gnu/linux-libre-$_basekernel-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/$_pkgver-gnu/patch-$_basekernel-gnu-$_pkgver-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/$_pkgver-gnu/patch-$_basekernel-gnu-$_pkgver-gnu.xz"
'cpupower.default'
'cpupower.systemd'
'cpupower.service'
'usbipd.service'
'01-fix-perf-python.patch'
'02-parabola-paths.patch'
- '03-fix-acpidump-compile-error.patch')
-sha256sums=('93450dc189131b6a4de862f35c5087a58cc7bae1c24caa535d2357cc3301b688'
- 'ffc3b2c30f38bcdaac32f2236651d1339ef4a9c2a70669938cdc1768440ce5d0'
+ '03-fix-tmon-ltinfo.patch')
+sha256sums=('9c2a524c901febe0f0138f702bfdeb52d6f79f22c1fdbabaa37580bc70f16218'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
'fce128f5e0abfa6916d5cb881456d892d1b163b9639166a4c6c1d53e4dc5086a'
'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570'
- 'c791c9eb95e9db28b5a6530232885def9de941d0cbeb9e8b3b999f0567de3199')
+ '7547815bb761d49d198b85f95011535713c2ed4a004f249a9cf6ba985af8c4ed')
prepare() {
cd linux-$pkgver
@@ -63,9 +62,7 @@ prepare() {
fi
patch -N -p1 -i "$srcdir/01-fix-perf-python.patch"
patch -N -p1 -i "$srcdir/02-parabola-paths.patch"
- # the following patch is a fix for compile error in 3.15
- # in the 3.16 acpidump code has been reimplemented and patch is not needed.
- patch -N -p1 -i "$srcdir/03-fix-acpidump-compile-error.patch"
+ patch -N -p1 -i "$srcdir/03-fix-tmon-ltinfo.patch"
}
build() {