summaryrefslogtreecommitdiff
path: root/libre/luxrender/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-02-16 11:42:18 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-02-16 11:42:18 -0200
commitda8700b7d177924c7128c14e766b4f28f443ec1d (patch)
tree313a3f1c6f49793c525d8a716e42320821244bdf /libre/luxrender/PKGBUILD
parent1c7701090ea8aeaa377ee5d57f548af92e449ed9 (diff)
luxrender-1.4-1.parabola1: updating version
Diffstat (limited to 'libre/luxrender/PKGBUILD')
-rw-r--r--libre/luxrender/PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/libre/luxrender/PKGBUILD b/libre/luxrender/PKGBUILD
index 86228ff8c..75d11ed85 100644
--- a/libre/luxrender/PKGBUILD
+++ b/libre/luxrender/PKGBUILD
@@ -1,51 +1,45 @@
+# $Id: PKGBUILD 127777 2015-02-16 09:41:50Z stativ $
# Maintainer (Arch): Lukas Jirkovsky <l.jirkovsky@gmail.com>
# Contributor (Arch): flixie <69one@gmx.net>
# Contributor (Arch): Imanol Celaya <ornitorrincos@archlinux-es.org>
# Maintainer: Márcio Silva <coadde@parabola.nu>
pkgname=luxrender
-pkgver=1.3.1
-_pkgver=d0b0e20c47cc
-pkgrel=11.parabola1
-pkgdesc='Rendering system for physically correct, unbiased image synthesis, without nonfree opencl-nvidia, amdapp-sdk and intel-opencl-runtime recommendation'
+pkgver=1.4
+_pkgver=dfd211d6faa0
+pkgrel=1.parabola1
+pkgdesc="Rendering system for physically correct, unbiased image synthesis, without nonfree opencl-nvidia, amdapp-sdk and intel-opencl-runtime recommendation"
arch=('i686' 'x86_64' 'mips64el')
url="http://www.$pkgname.net/"
license=('GPL')
-depends=('boost-libs' 'freeimage' 'openexr' 'libpng' 'libcl' 'libgl' 'fftw')
+depends=('boost-libs' 'freeimage' 'openexr' 'openimageio' 'libpng' 'libcl' 'libgl' 'fftw')
optdepends=('blender-addon-luxrender: Blender exporter' 'qt4: Qt GUI'
'python: pylux Python interface'
'opencl-mesa: OpenCL support for AMD/ATI GPUs')
-# luxrender is constantly broken to various GCC bugs, the latest one being FS#40596
-makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays=$pkgver" 'python' 'opencl-headers' 'clang')
+makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays=$pkgver" 'python' 'opencl-headers')
conflicts=("$pkgname-libre" "$pkgname-parabola")
replaces=("$pkgname-libre" "$pkgname-parabola")
source=("https://bitbucket.org/$pkgname/lux/get/$_pkgver.tar.bz2"
"force_python3.diff")
-md5sums=('cbe749f56a1e1976745f5458100efa8a'
+md5sums=('7591ac4e86d0232245af38f6cf932c02'
'42692e65eabc5828693e2682e94b7c64')
prepare() {
cd $srcdir/$pkgname-lux-$_pkgver
- # fix library path on 64bit
- sed -i '\|SET[(]LIB_SUFFIX 64[)]|d' CMakeLists.txt
-
- patch -Np1 < $srcdir/force_python3.diff || true
- # workaround QTBUG-22829
- find . -type f -exec sed -i 's|^#include .*boost/.*|#ifndef Q_MOC_RUN\n&\n#endif|' '{}' ';'
+ patch -Np1 < "$srcdir/force_python3.diff" || true
}
build() {
cd $srcdir/$pkgname-lux-$_pkgver
- export CC=clang
- export CXX=clang++
- cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DLUXRAYS_DISABLE_OPENCL=OFF \
-DPYTHON_CUSTOM=ON \
-DPYTHON_LIBRARIES=/usr/lib/libpython3.4m.so \
-DPYTHON_INCLUDE_PATH=/usr/include/python3.4m/ \
- -DCMAKE_EXE_LINKER_FLAGS=-lpthread
+ -DCMAKE_EXE_LINKER_FLAGS=-lpthread \
+ .
make
}
@@ -53,6 +47,9 @@ package() {
cd $srcdir/$pkgname-lux-$_pkgver
make DESTDIR=$pkgdir install
+ # fix library path on x86_64
+ [ "$CARCH" = "x86_64" ] && mv "$pkgdir"/usr/lib64 "$pkgdir"/usr/lib
+
#install pylux
install -D -m644 pylux.so $pkgdir/usr/lib/python3.4/pylux.so
}