summaryrefslogtreecommitdiff
path: root/libre/mc/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-10-07 15:27:36 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-10-07 15:27:36 -0300
commit2c90e4bdeac796875378381f62c216b50d299d43 (patch)
tree006720553e9cbfb5f3b8548a9f7c3bee02358bac /libre/mc/PKGBUILD
parent933d40bd031440b5058604b9fb27a208b7c279c6 (diff)
mc-4.8.18-1.parabola1: updating version
Diffstat (limited to 'libre/mc/PKGBUILD')
-rw-r--r--libre/mc/PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/libre/mc/PKGBUILD b/libre/mc/PKGBUILD
index d30c644c3..67865ed32 100644
--- a/libre/mc/PKGBUILD
+++ b/libre/mc/PKGBUILD
@@ -1,12 +1,12 @@
-# $Id: PKGBUILD 190233 2016-09-24 07:17:41Z schuay $
+# $Id: PKGBUILD 191561 2016-10-07 15:41:12Z schuay $
# Maintainer (Arch): schuay <jakob.gruber@gmail.com>
# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
# Maintainer: André Silva <emulatorman@parabola.nu>
# Contributor: Márcio Silva <coadde@parabola.nu>
pkgname=mc
-pkgver=4.8.17
-pkgrel=2.parabola1
+pkgver=4.8.18
+pkgrel=1.parabola1
pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander, with arj recommendation included and nonfree unace and unrar support removed"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.ibiblio.org/mc/"
@@ -38,19 +38,12 @@ backup=('etc/mc/edit.indent.rc'
'etc/mc/sfs.ini')
options=('!emptydirs')
source=("http://ftp.midnight-commander.org/${pkgname}-${pkgver}.tar.xz"
- "0001-Ticket-3639-fix-window-resizing-when-panels-are-hidd.patch"
- "0002-Do-not-botch-SIGWINCH-delivery-to-the-subshell.patch"
'libre.patch')
-sha256sums=('0447bdddc0baa81866e66f50f9a545d29d6eebb68b0ab46c98d8fddd2bf4e44d'
- '9a3639ff068dfddee0342d631b56d8df6c0240105802fb00edb0fa3a265e95d6'
- '2a5ab735226ce41b0ebbb4bcedb0e04e82ea3cb14e2776acede1e58816f3d787'
+sha256sums=('f7636815c987c1719c4f5de2dcd156a0e7d097b1d10e4466d2bdead343d5bece'
'a72558445fd1558e18d0fb0be767f4460d04130e80cd87ad84b376fab1b66357')
prepare() {
cd ${pkgname}-${pkgver}
- patch -Np1 < ${srcdir}/0001-Ticket-3639-fix-window-resizing-when-panels-are-hidd.patch
- patch -Np1 < ${srcdir}/0002-Do-not-botch-SIGWINCH-delivery-to-the-subshell.patch
-
patch -Np1 -i ../libre.patch
rm -v src/vfs/extfs/helpers/u{ace,rar}.in
}
@@ -60,7 +53,7 @@ build() {
cd ${pkgname}-${pkgver}
./configure \
- --prefix=/usr \
+ --prefix=/usr \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--enable-vfs-smb \
@@ -71,4 +64,7 @@ build() {
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+
+ # Replace mc.keymap symlink with target file to fix backup mechanism (FS#50889).
+ rm "${pkgdir}"/etc/mc/mc.keymap && cp "${pkgdir}"/etc/mc/mc{.default,}.keymap
}