summaryrefslogtreecommitdiff
path: root/libre/minitube/PKGBUILD
diff options
context:
space:
mode:
authorfauno <fauno@endefensadelsl.org>2017-09-04 14:06:45 -0300
committerfauno <fauno@endefensadelsl.org>2017-09-04 14:06:45 -0300
commit9285de9d87218c05dce0eaeeed9c92bf810a2b45 (patch)
treeab63e467421bf8a9793026e49d007aeb12b3c009 /libre/minitube/PKGBUILD
parente81cebe2a2e70e6e6408aa8e3636fba442de1e26 (diff)
minitube: remove unfree recommendations #1457
Diffstat (limited to 'libre/minitube/PKGBUILD')
-rw-r--r--libre/minitube/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/libre/minitube/PKGBUILD b/libre/minitube/PKGBUILD
new file mode 100644
index 000000000..563c20968
--- /dev/null
+++ b/libre/minitube/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: fauno <fauno@parabola.nu>
+# Maintainer (Arch): speps <speps at aur dot archlinux dot org>
+# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=minitube
+pkgver=2.8
+pkgrel=2.parabola1
+pkgdesc="A native YouTube client in Qt. Watch YouTube videos without Flash Player and nonfree recommendations"
+arch=('i686' 'x86_64')
+url='http://flavio.tordini.org/minitube'
+license=('GPL3')
+depends=('phonon-qt5' 'qt5-declarative' 'hicolor-icon-theme')
+makedepends=('qt5-tools')
+source=(https://repo.parabola.nu/other/${pkgname}/${pkgname}-${pkgver}-libre${_srcrel}.tar.gz)
+sha512sums=('a9b54f2120c9404a492380bffcffa210a92eebfe7702df6124a0e8ebec1a9031b96e3daa601f0e076b1748cbe0e094e8347e915c564369e6a4cfd4441495a9d3')
+mksource=($pkgname-$pkgver.tar.gz::"https://github.com/flaviotordini/minitube/archive/$pkgver.tar.gz"
+ remove_unfree_recommendations.patch)
+mksha256sums=('c8e7c39d5125027d076440830c6cc33d2782e0d65047d639dfa55e839e64d88c'
+ '6486ebc95349f906b1cbbf9104b03909875c68c0db199748562b77ac39bbb50f')
+
+mksource() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../remove_unfree_recommendations.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ qmake
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make install INSTALL_ROOT="$pkgdir/"
+}