summaryrefslogtreecommitdiff
path: root/libre/mplayer/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-02-12 16:47:13 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-02-12 16:47:13 -0500
commitd42fa3a3a3f586ff497943b51646e9ace0078312 (patch)
treea624dd9e6dd014beee8ba3da286c1ba9d0d4a736 /libre/mplayer/PKGBUILD
parent45a9529a0ed72ccd5d1a69468d741e26a8cd2d24 (diff)
mplayer: armv7h port
Diffstat (limited to 'libre/mplayer/PKGBUILD')
-rw-r--r--libre/mplayer/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/libre/mplayer/PKGBUILD b/libre/mplayer/PKGBUILD
index 82e83e8e6..e556dd62c 100644
--- a/libre/mplayer/PKGBUILD
+++ b/libre/mplayer/PKGBUILD
@@ -40,12 +40,16 @@ prepare() {
build() {
cd ${pkgbase}-${pkgver}
- export CFLAGS="${CFLAGS/-march=x86-64/}"
- export CFLAGS="${CFLAGS/-mtune=generic/}"
+
+ # CPU detection doesn't work in ARM
+ if [ "$CARCH" != "armv7h" ]; then
+ extra=--enable-runtime-cpudetection
+ fi
+
export LDFLAGS="${LDFLAGS/,O1/}"
export LDFLAGS="${LDFLAGS/,--sort-common/}"
./configure --prefix=/usr \
- --enable-runtime-cpudetection \
+ $extra \
--disable-gui \
--disable-arts \
--disable-liblzo \