summaryrefslogtreecommitdiff
path: root/libre/mplayer/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-19 13:23:58 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-19 13:23:58 -0300
commitfc1df8ed8f68f8646bc0323da38c3cbbc319d8f1 (patch)
tree7feb4f0e51cc5fb06b3335882949ccdeb201d46a /libre/mplayer/PKGBUILD
parentad95ee55a1dd0cd009e39b310523c48f9b86852d (diff)
mplayer-37916-1.parabola1: updating version
Diffstat (limited to 'libre/mplayer/PKGBUILD')
-rw-r--r--libre/mplayer/PKGBUILD97
1 files changed, 34 insertions, 63 deletions
diff --git a/libre/mplayer/PKGBUILD b/libre/mplayer/PKGBUILD
index 439da24e5..737c09c12 100644
--- a/libre/mplayer/PKGBUILD
+++ b/libre/mplayer/PKGBUILD
@@ -1,5 +1,5 @@
-# $Id: PKGBUILD 266899 2016-05-04 21:39:36Z arojas $
-# Maintainer (Arch): Ionut Biru <ibiru@archlinux.org>
+# Maintainer (Arch): Levente Polyak <anthraxx@archlinux.org>
+# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor (Arch): Hugo Doria <hugo@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -7,50 +7,35 @@
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
-pkgver=37857
+pkgver=37916
pkgrel=1.parabola1
+pkgdesc='Media player for GNU/Linux, without using of UnRAR executable and nonfree faac support'
+url='http://www.mplayerhq.hu/'
arch=('i686' 'x86_64' 'armv7h')
-makedepends=(
- 'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
- 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'jack' 'libcaca'
- 'faad2' 'lirc' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
- 'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
- 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
- 'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gnutls'
- 'gsm' 'libdvdcss' 'libdvdread' 'libdvdnav' 'ffmpeg'
-)
license=('GPL')
-url='http://www.mplayerhq.hu/'
+makedepends=('libxxf86dga' 'libmad' 'libxinerama' 'libmng' 'libxss' 'smbclient' 'aalib' 'jack'
+ 'libcaca' 'faad2' 'lirc' 'libxvmc' 'enca' 'libdca' 'a52dec' 'libvpx' 'unzip'
+ 'mesa' 'live-media' 'yasm' 'git' 'mpg123' 'ladspa' 'libcdio-paranoia' 'subversion'
+ 'x264' 'libx264' 'rtmpdump' 'libdvdcss' 'libdvdread' 'libdvdnav' 'ffmpeg')
options=('!buildflags' '!emptydirs')
-source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
+source=(${pkgbase}-${pkgver}::svn://svn.mplayerhq.hu/mplayer/trunk#revision=${pkgver}
mplayer.desktop
include-samba-4.0.patch
- ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
revert-icl-fixes.patch)
-md5sums=('SKIP'
- '62f44a58f072b2b1a3c3d3e4976d64b3'
- '868a92bdef148df7f38bfa992b26ce9d'
- '71be9bcd297cb9ce833bbc5d425c0470'
- '3579402002b7302fdf2d146639333efd')
-
-#pkgver() {
-# cd $pkgbase-$pkgver
-# svnversion
-#}
+sha512sums=('SKIP'
+ 'd3c5cbf0035279c6f307e4e225473d7b77f9b56566537a26aa694e68446b9e3240333296da627ad5af83b04cc8f476d1a3f8c05e4cf81cd6e77153feb4ed74bc'
+ '9debb8c58b996f6c716c22c86c720bf9dc49b4ee9b76c57519f791667ae1de2cc6f5add878fbf4ac02c6b6fd1865e1bcfa6105e75de4bf7ec596c338ed0cae99'
+ '0cae0b26d3d97fd4c962962c43a481de20335369cbca406cadfc9bda1a0608b32f5374e76c477cb9a85bda83a568a1ed17126df224ae61579d0a402c1824aea8')
prepare() {
- cd $pkgbase-$pkgver
-# mv ../ffmpeg-*/ ./ffmpeg
-
- patch -Np1 -i ../include-samba-4.0.patch
- patch -Np0 -i ../revert-icl-fixes.patch
-# patch -d ffmpeg -Np1 <../ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
-
+ cd ${pkgbase}-${pkgver}
+ patch -p1 < "../include-samba-4.0.patch"
+ patch -p0 < "../revert-icl-fixes.patch"
./version.sh
}
build() {
- cd $pkgbase-$pkgver
+ cd ${pkgbase}-${pkgver}
# CPU detection doesn't work in ARM
if [ "$CARCH" != "armv7h" ]; then
@@ -79,51 +64,37 @@ build() {
--language=all \
--confdir=/etc/mplayer \
$extra
- [[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
-
+ [[ "${CARCH}" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
make
}
package_mplayer() {
pkgdesc='Media player for GNU/Linux, without using of UnRAR executable and nonfree faac support'
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
- depends=(
- 'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
- 'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
- 'libgl' 'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore'
- 'opencore-amr' 'jack' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
- 'fribidi' 'libjpeg' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
- 'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
- 'gsm' 'gnutls' 'libdvdnav' 'ffmpeg'
- )
+ depends=('desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
+ 'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'libxinerama' 'smbclient'
+ 'jack' 'libmad' 'libcaca' 'libxxf86dga' 'faad2' 'libxvmc' 'mpg123'
+ 'libcdio-paranoia' 'rtmpdump' 'libdvdnav' 'ffmpeg')
replaces=('mplayer-libre' 'mplayer-parabola')
conflicts=('mplayer-libre' 'mplayer-parabola')
- cd $pkgbase-$pkgver
- make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR="${pkgdir}" install-mplayer install-mplayer-man
- install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
- "$pkgdir/etc/mplayer/"
-
- # desktop file (FS#14770)
- install -Dm644 ../mplayer.desktop \
- "$pkgdir"/usr/share/applications/mplayer.desktop
- install -Dm644 etc/mplayer256x256.png \
- "$pkgdir"/usr/share/pixmaps/mplayer.png
+ install -Dm 644 etc/{codecs.conf,input.conf,example.conf} "${pkgdir}/etc/mplayer"
+ install -Dm 644 "${srcdir}/mplayer.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm 644 etc/mplayer256x256.png "${pkgdir}/usr/share/pixmaps/mplayer.png"
}
package_mencoder() {
pkgdesc='Free command line video decoding, encoding and filtering tool, without using of UnRAR executable and nonfree faac support'
- depends=(
- 'enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'bzip2' 'lame'
- 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
- 'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faad2'
- 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
- 'libvorbis' 'opus' 'rtmpdump' 'gsm' 'libdvdnav' 'ffmpeg'
- )
+ depends=('enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'smbclient' 'libmad'
+ 'faad2' 'mpg123' 'libcdio-paranoia' 'rtmpdump' 'libdvdnav' 'ffmpeg')
replaces=('mencoder-libre' 'mencoder-parabola')
conflicts=('mencoder-libre' 'mencoder-parabola')
- make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
- find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
+ make -C ${pkgbase}-${pkgver} DESTDIR="${pkgdir}" install-mencoder install-mencoder-man
+ find "${pkgdir}/usr/share/man" -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
}
+
+# vim: ts=2 sw=2 et: