summaryrefslogtreecommitdiff
path: root/libre/p7zip/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-04-16 18:54:33 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-04-16 19:01:11 -0300
commit5075361afc8a19799e5313510610ad413ff058e0 (patch)
tree8d6d296e46172ba7dd92f6017501c17c84f9a8b7 /libre/p7zip/PKGBUILD
parent833a32fa22a55153e08932eb1d1d37a5ca7ab4dc (diff)
p7zip-9.38.1-3.parabola1: updating revision from Arch
Drop the 7zFM graphical frontend; we don't want to have to depend on wxgtk and the interface itself is a bit unintuitive. Alternative GUI archive managers include: file-roller, engrampa, kdeutils-ark.
Diffstat (limited to 'libre/p7zip/PKGBUILD')
-rw-r--r--libre/p7zip/PKGBUILD102
1 files changed, 42 insertions, 60 deletions
diff --git a/libre/p7zip/PKGBUILD b/libre/p7zip/PKGBUILD
index 5c9feddfd..36b595824 100644
--- a/libre/p7zip/PKGBUILD
+++ b/libre/p7zip/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 235997 2015-04-09 21:04:58Z bisson $
+# $Id: PKGBUILD 237196 2015-04-15 21:18:25Z foutrelis $
# Contributor (Arch): Thayer Williams <thayer@archlinux.org>
# Contributor (Arch): Hugo Doria <hugo@archlinux.org>
# Contributor (Arch): TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
@@ -9,87 +9,69 @@
_pkgname=p7zip-libre
pkgname=p7zip
pkgver=9.38.1
-pkgrel=2.parabola1
-pkgdesc='Command-line version of the 7zip compressed file archiver, without nonfree decompression engine for RAR archives'
-url='http://p7zip.sourceforge.net/'
-license=('GPL')
+pkgrel=3.parabola1
+pkgdesc="Command-line file archiver with high compression ratio"
arch=('i686' 'x86_64' 'mips64el')
+url="http://p7zip.sourceforge.net/"
+license=('LGPL')
conflicts=('p7zip-libre')
replaces=('p7zip-libre')
-depends=('gcc-libs' 'bash')
-optdepends=('wxgtk: GUI'
- 'desktop-file-utils: desktop entries')
-makedepends=('yasm' 'nasm' 'wxgtk')
+depends=('gcc-libs' 'sh')
+makedepends_i686=('nasm')
+makedepends_x86_64=('yasm')
+install=$pkgname.install
mksource=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2")
source=("https://repo.parabola.nu/other/${_pkgname}/${_pkgname}_${pkgver}_src_all.tar.bz2"
- 'osversion.patch'
- '7zFM.desktop'
'libre.patch')
-mksha1sums=('6b1eccf272d8b141a94758f80727ae633568ba69')
-sha1sums=('8c4dbbcd4d9c80d48c549318bf6ab71819904acc'
- '8c086db1c7be0d52d2ac971f44adbdccf6dd82de'
- '441e8d89457f165c22015dedd0c1ee88504f333c'
- '33821327ea734f218ed284ff03e8a0d0ac945070')
-
-options=('!makeflags')
-install=install
+mksha256sums=('fd5019109c9a1bf34ad3257d37a6853eae8151ff50345f0a3ffba7d8c5fdb995')
+sha256sums=('ef4011f2d2387d8e11d504aaf603b1a4d92984c281784fe7663b74ba952f8d7e'
+ '1a1f779471532d30a8722f563f3189932f955b57bb1a94a32b7aa3a31dcd34ed')
mksource() {
- cd "${srcdir}/${pkgname}_${pkgver}"
+ cd "${srcdir}/${pkgname}_${pkgver}"
- # Remove nonfree unRAR utility files from the source
- rm -rv CPP/7zip/{Archive,Compress}/Rar
- rm -v CPP/7zip/Compress/{Rar{1,2,3}Decoder.{cpp,h},Rar3Vm.{cpp,h},RarCodecsRegister.cpp}
- rm -v CPP/7zip/Crypto/{Rar20Crypto,RarAes}.{cpp,h}
- rm -v Utils/file_Codecs_Rar29_so.py
- rm -v DOC/unRarLicense.txt
+ # Remove nonfree unRAR utility files from the source
+ rm -rv CPP/7zip/{Archive,Compress}/Rar
+ rm -v CPP/7zip/Compress/{Rar{1,2,3}Decoder.{cpp,h},Rar3Vm.{cpp,h},RarCodecsRegister.cpp}
+ rm -v CPP/7zip/Crypto/{Rar20Crypto,RarAes}.{cpp,h}
+ rm -v Utils/file_Codecs_Rar29_so.py
+ rm -v DOC/unRarLicense.txt
- # Remove nonfree parent folder icon
- rm CPP/7zip/UI/FileManager/res/ParentFolder.h
+ # Remove nonfree parent folder icon
+ rm CPP/7zip/UI/FileManager/res/ParentFolder.h
}
prepare() {
- cd "${srcdir}/${pkgname}_${pkgver}"
- [[ $CARCH = x86_64 ]] &&
- cp makefile.linux_amd64_asm makefile.machine ||
- cp makefile.linux_x86_asm_gcc_4.X makefile.machine
-
- patch -p1 -i ../osversion.patch
- sed -i 's/x86_64-linux-gnu//g' CPP/7zip/*/*/*.depend
+ cd "$srcdir/${pkgname}_$pkgver"
- rm GUI/kde4/p7zip_compress.desktop # FS#43766
+ if [[ $CARCH = x86_64 ]]; then
+ cp makefile.linux_amd64_asm makefile.machine
+ else
+ cp makefile.linux_x86_asm_gcc_4.X makefile.machine
+ fi
- # remove rar and parent folder icon references
- patch -Np1 -i ../libre.patch
+ # remove rar and parent folder icon references
+ patch -Np1 -i ../libre.patch
}
build() {
- cd "${srcdir}/${pkgname}_${pkgver}"
- make all4 OPTFLAGS="${CXXFLAGS}"
+ cd "$srcdir/${pkgname}_$pkgver"
+ make all3 OPTFLAGS="$CFLAGS"
}
package() {
- cd "${srcdir}/${pkgname}_${pkgver}"
- make install \
- DEST_DIR="${pkgdir}" \
- DEST_HOME="/usr" \
- DEST_MAN="/usr/share/man"
+ cd "$srcdir/${pkgname}_$pkgver"
- # Doc and licenses
- cp -a DOC/* "${pkgdir}"/usr/share/doc/p7zip
- install -d "${pkgdir}"/usr/share/licenses/p7zip
- ln -s -t "${pkgdir}"/usr/share/licenses/p7zip \
- /usr/share/doc/p7zip/License.txt
+ make install \
+ DEST_DIR="$pkgdir" \
+ DEST_HOME=/usr \
+ DEST_MAN=/usr/share/man
- # Integration with stuff...
- install -Dm644 GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
- install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
- cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
- cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/
- ln -s 7zCon.sfx "${pkgdir}"/usr/lib/p7zip/7z.sfx
+ install -d "${pkgdir}"/usr/share/licenses/p7zip
+ ln -s -t "$pkgdir/usr/share/licenses/p7zip/" \
+ /usr/share/doc/p7zip/DOC/License.txt
- find GUI/help -type d -exec chmod 755 {} \;
- cp -r GUI/help "${pkgdir}"/usr/lib/p7zip/
-
- chmod -R a+r,u+w,a+X "${pkgdir}/usr"
+ chmod -R a+r,u+w,a+X "$pkgdir/usr"
}
+
+# vim:set ts=2 sw=2 et: