summaryrefslogtreecommitdiff
path: root/libre/pacman/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-04-29 19:40:53 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-04-29 20:36:34 -0400
commit05511a5a6ffe0a329e6b28edeabf1d1f62fb9091 (patch)
treeb7c0a09e9a4ca65942cd97c9cddb689bb35bcaf0 /libre/pacman/PKGBUILD
parent9b03d350a82fa3a3c87db105a909a74e9f4e4106 (diff)
libre/pacman: Remove old hacks, tidy up, enable debug packages
Maintenance: - Bump pkgrel 2.parabola1.3 -> 2.parabola2 Old hacks: - Remove conflicts/replaces on cacert-dot-org. Prior to 2016 it depended on core/ca-certificates-cacert, which in 2014 replaced libre/cacert-dot-org. With That dependency dropped, there's no reason to keep this hack around. - Remove the openssl-1.0 -> 1.1 upgrade hack - Drop optdepend on cron; the cron file hasn't been shipped since 2015 Fixup: - Adjust PKGBUILD to reduce pointless diff with Arch's PKGBUILD - provides+=('pacman-parabola') for symmetry with conflicts and replaces - pacman-keyring.timer: WantedBy=timers.target, not multi-user.target - pacman-keyring.service: Add Documentation= to match the .timer Changes: - enable pacman-keyring.timer by default ( via systemd.preset(5) ) - makepkg.conf: Build debug packages by default
Diffstat (limited to 'libre/pacman/PKGBUILD')
-rw-r--r--libre/pacman/PKGBUILD52
1 files changed, 30 insertions, 22 deletions
diff --git a/libre/pacman/PKGBUILD b/libre/pacman/PKGBUILD
index 5100c96fa..2dbefbe75 100644
--- a/libre/pacman/PKGBUILD
+++ b/libre/pacman/PKGBUILD
@@ -11,31 +11,35 @@
pkgname=pacman
pkgver=5.0.2
-pkgrel=2.parabola1.3
+pkgrel=2
+pkgrel+=.parabola2
pkgdesc="A library-based package manager with dependency support"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('i686' 'x86_64')
+arch+=('armv7h')
url="http://www.archlinux.org/pacman/"
license=('GPL')
-groups=('base' 'base-devel' 'base-openrc')
-depends=('bash' 'glibc' 'libarchive' 'curl' 'gpgme'
- 'pacman-mirrorlist' 'archlinux-keyring' 'parabola-keyring'
- 'archlinuxarm-keyring' 'archlinux32-keyring')
+groups=('base' 'base-devel')
+groups+=('base-openrc')
+depends=('bash' 'glibc' 'libarchive' 'curl'
+ 'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
+depends+=('parabola-keyring' 'archlinuxarm-keyring' 'archlinux32-keyring')
makedepends=('asciidoc')
-makedepends+=('openssl>=1.1' 'openssl-1.0') # for during openssl 1.0->1.1 rebuild; remove on next rebuild
checkdepends=('python2' 'fakechroot')
-optdepends=('cron: run specified programs at scheduled times and related tools')
-provides=("$pkgname-contrib")
-conflicts=("$pkgname-contrib" "$pkgname-parabola" 'cacert-dot-org')
-replaces=("$pkgname-contrib" "$pkgname-parabola" 'cacert-dot-org')
-backup=('etc/pacman.conf' 'etc/makepkg.conf')
+provides=('pacman-contrib')
+provides+=('pacman-parabola')
+conflicts=('pacman-contrib')
+conflicts+=('pacman-parabola')
+replaces=('pacman-contrib')
+replaces+=('pacman-parabola')
+backup=(etc/pacman.conf etc/makepkg.conf)
options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
- "${arch[@]/#/$pkgname.conf.}"
+ "${arch[@]/#/pacman.conf.}"
makepkg.conf.in
- $pkgname-keyring.service
- $pkgname-keyring.timer
+ pacman-keyring.service
+ pacman-keyring.timer
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
@@ -45,9 +49,9 @@ sha256sums=('dfd36086ad68564bcd977f4a1fafe51dd328acd4a95093ac4bf1249be9c41f0e'
'19853ea9a2138157bbb334eb7f3a9b3098b88e513678b54b7b4f19d2ffd6ecad'
'1b2c8f4ec84d0dc496516880a54b5e4deb78798618c9cf5e284a45303f156e58'
'b2cb3ba229edba338c0af7d7f5bb1a6ef6143bcd453c693bfee0c02fa1cfa18a'
- '0d174c7c47921cfbb35dacb9d099095e78f6f67bfaa86836a3e588552f14ed03'
- '1df848c5038a3f81ae4dc79a4072d340109b02f56292a5c4a20c59f735edd2b3'
- '1cc4af1cf8e2133d4520827cc7d3ffad731892595f8e699909002d2e40ad8df9'
+ '117892e340cc502b8659f21b209886c51a375e52f4af39f173ff7fe12762d40b'
+ '220f1b25a64727041dc6fa3fd486b0a043f735a3f6cecedc4e2f7c47ec6ce66d'
+ '2a857061f032ff5485f5c75ab74e6f6532621e08963ef48640a792cca16cacd6'
'6064bbf5b453ec50b25291cf9268c56cac4bca3ad80d47f2d6b62c82254e5461'
'dbadad986353ff90a390614f393a09ea07498fcf00467481bc58fbc07ac2d003'
'4187d385e173127df8ed6d358291f0a0b0c2581742d8859ad6b276bb6d703e49'
@@ -75,7 +79,7 @@ build() {
--with-scriptlet-shell=/usr/bin/bash \
--with-ldconfig=/usr/bin/ldconfig
make V=1
- make -C contrib
+ make -C contrib
# Generate the architecture-specific makepkg.conf files
local carch mycarch mychost myflags myldflags
@@ -118,15 +122,15 @@ package() {
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" -C contrib install
- # install Parabola specific stuff
+ # install distro-specific stuff
install -dm755 "$pkgdir/etc"
- install -m644 "$srcdir/$pkgname.conf.$CARCH" "$pkgdir/etc/$pkgname.conf"
+ install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
install -m644 "$srcdir/makepkg.conf.$CARCH" "$pkgdir/etc/makepkg.conf"
install -dm755 "$pkgdir/usr/share/pacman/defaults"
local carch
for carch in "${arch[@]}"; do
- install -m644 "$srcdir/$pkgname.conf.$carch" "$pkgdir/usr/share/pacman/defaults/"
+ install -m644 "$srcdir/pacman.conf.$carch" "$pkgdir/usr/share/pacman/defaults/"
install -m644 "$srcdir/makepkg.conf.$carch" "$pkgdir/usr/share/pacman/defaults/"
done
@@ -141,6 +145,10 @@ package() {
install -Dm644 contrib/PKGBUILD.vim "$pkgdir/usr/share/vim/vimfiles/syntax/PKGBUILD.vim"
+ # Parabola's pacman began shipping a weekly job for this back in
+ # 2014. Why is it nescessary for Parabola installs, but it
+ # seemingly isn't for Arch installs?
install -Dm644 "$srcdir/pacman-keyring.service" "$pkgdir/usr/lib/systemd/system/pacman-keyring.service"
install -Dm644 "$srcdir/pacman-keyring.timer" "$pkgdir/usr/lib/systemd/system/pacman-keyring.timer"
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/systemd/system-preset/90-pacman.preset" <<<"enable pacman-keyring.timer"
}