summaryrefslogtreecommitdiff
path: root/libre/parabola-gnome/PKGBUILD
diff options
context:
space:
mode:
authorDrtan Samos <lashdu@drtan.twilightparadox.com>2014-05-04 19:54:05 +0200
committerDrtan Samos <lashdu@drtan.twilightparadox.com>2014-05-04 19:54:05 +0200
commitcb642f59b30bb1f1b1648acba05382c268905237 (patch)
tree168f617a2a55cc67634913fd19069b9dc8fd96af /libre/parabola-gnome/PKGBUILD
parent6c8f8bda971e55460b59ba4f088414908c19f39d (diff)
parabola-gnome-1.0.1-1: updating version
Diffstat (limited to 'libre/parabola-gnome/PKGBUILD')
-rw-r--r--libre/parabola-gnome/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/libre/parabola-gnome/PKGBUILD b/libre/parabola-gnome/PKGBUILD
new file mode 100644
index 000000000..6a1984114
--- /dev/null
+++ b/libre/parabola-gnome/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Drtan Samos <lashdu@drtan.twilightparadox.com>
+
+pkgname=parabola-gnome
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="The Parabola defaults for GNOME"
+arch=('any')
+url="https://parabolagnulinux.org"
+license=('GPL3')
+options=('!emptydirs')
+install=$pkgname.install
+depends=('dbus-glib' 'parabola-artwork>=1.0' 'parabola-artwork<1.1')
+source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}-${pkgver}-${pkgrel}.tar.gz")
+sha256sums=('9d78c93ea39da8561ff7c7eb822e8ea530609cc4991becae2d0741d2543f69d1')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}-${pkgrel}
+ install -d ${pkgdir}/usr/share/gnome-background-properties/
+ install -Dm644 gnome-background-properties/parabola.xml "${pkgdir}/usr/share/gnome-background-properties/"
+ install -Dm644 dconf/db/gdm.d/parabola "${pkgdir}/etc/dconf/db/gdm.d/$(date +%Y%m%d%H%M%S%N)"
+ install -Dm644 dconf/db/local.d/parabola "${pkgdir}/etc/dconf/db/local.d/$(date +%Y%m%d%H%M%S%N)"
+ install -d ${pkgdir}/etc/dconf/profile/
+ install -m644 dconf/profile/* "${pkgdir}/etc/dconf/profile/"
+}
+