summaryrefslogtreecommitdiff
path: root/libre/parabolaweb-git/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-05-06 21:38:45 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-05-06 21:38:45 -0400
commite1f7b97ab1603aea664ee3f392f6263fd7812b3c (patch)
tree14064440a599fb23ec41d0302f408be1f235eae9 /libre/parabolaweb-git/PKGBUILD
parentef70ca717bdecae1b909b8b24970e81eee20b985 (diff)
mv ~lukeshu/parabolaweb-git libre/parabolaweb-git
Diffstat (limited to 'libre/parabolaweb-git/PKGBUILD')
-rw-r--r--libre/parabolaweb-git/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/libre/parabolaweb-git/PKGBUILD b/libre/parabolaweb-git/PKGBUILD
new file mode 100644
index 000000000..4641ea8d3
--- /dev/null
+++ b/libre/parabolaweb-git/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+pkgname=parabolaweb-git
+pkgver=20120506
+pkgrel=3
+pkgdesc="The Parabola website, fork of archweb"
+arch=('any')
+url="https://projects.parabolagnulinux.org/parabolaweb.git/"
+license=('GPL2')
+
+_deps_file=deps-ver.txt
+#_deps_file=deps-nover.txt
+make "$_deps_file" 1>&2
+depends=('python2' 'git' 'libretools' `cat $_deps_file`)
+
+source=('parabolaweb.init.sh' 'parabolaweb.update.sh.in')
+
+# These will make it install into /http/srv/web
+_install_dir=/srv/http
+_gitname=web
+
+_gitroot=https://projects.parabolagnulinux.org/parabolaweb.git
+_gitbranch="master"
+
+build() {
+ cd "${srcdir}"
+ sed \
+ -e "s|^_install_dir=.*|_install_dir='$_install_dir'|" \
+ -e "s|^_gitname=.*|_gitname='$_gitname'|" \
+ -e "s|^_gitroot=.*|_gitroot='$_gitroot'|" \
+ -e "s|^_gitbranch=.*|_gitbranch='$_gitbranch'|" \
+ < parabolaweb.update.sh.in > parabolaweb.update.sh
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/${_install_dir}"
+ install -Dm755 parabolaweb.init.sh "${pkgdir}/etc/rc.d/parabolaweb"
+ install -Dm755 parabolaweb.update.sh "${pkgdir}/usr/sbin/parabolaweb.update"
+}
+
+md5sums=('72bc7092e4e50a2aaca8b871644520d9'
+ 'f495b2e4623691925308cb4a1ec7e5a9')