summaryrefslogtreecommitdiff
path: root/libre/python2-bencode/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-26 00:00:44 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-26 00:00:44 -0600
commit23d897b9d2350accefe8784c08cde55b648a0a75 (patch)
treeb7de5f2642d89f67503913bb735273edbcc528c2 /libre/python2-bencode/PKGBUILD
parent06ad6a3f12629877f355f114dc5576107c03d14f (diff)
clean up dependencies of parabolaweb-utils (past and future versions)
- remove libre/django13: it has since upgraded to django=1.4 - fix libre/python2-cssmin-fredj: had metadata from python2-django-countries - add libre/python2-bencode: I don't know why it wasn't added. - add libre/python2-jsmin: re-licensed from JSON to MIT.
Diffstat (limited to 'libre/python2-bencode/PKGBUILD')
-rw-r--r--libre/python2-bencode/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/libre/python2-bencode/PKGBUILD b/libre/python2-bencode/PKGBUILD
new file mode 100644
index 000000000..762d55cad
--- /dev/null
+++ b/libre/python2-bencode/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+_pkgname=bencode
+pkgname=python2-bencode
+pkgver=1.0
+pkgdesc="BitTorrent bencode module as leight-weight, standalone package"
+url="http://pypi.python.org/pypi/BitTorrent-bencode"
+license=('custom:BitTorrent Open Source License')
+
+pkgrel=1
+arch=('any')
+depends=('python2')
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz
+ bittorrent-osl.txt)
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir"/bittorrent-osl.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums=('400dd42ff346eb7db91245403f8f2b7b'
+ '016d959cb9f7a319e48d9699c4ef2f42')