summaryrefslogtreecommitdiff
path: root/libre/sqlite3-libre/PKGBUILD
diff options
context:
space:
mode:
authorMichał Masłowski <mtjm@mtjm.eu>2012-04-01 10:49:36 +0200
committerMichał Masłowski <mtjm@mtjm.eu>2012-04-01 10:49:36 +0200
commitdd4d15387aaf8467bafe290c4a411a673f0e6426 (patch)
tree5f9524d19d51f9c2ad94a5087ac3f38ed18f3a9d /libre/sqlite3-libre/PKGBUILD
parent78e01fe7cbc0f7eb10615717fb3c6a618fcb6807 (diff)
sqlite3-libre, without nonfree sqlite3-doc.
Diffstat (limited to 'libre/sqlite3-libre/PKGBUILD')
-rw-r--r--libre/sqlite3-libre/PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/libre/sqlite3-libre/PKGBUILD b/libre/sqlite3-libre/PKGBUILD
new file mode 100644
index 000000000..97a36e1ce
--- /dev/null
+++ b/libre/sqlite3-libre/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 154652 2012-03-30 14:26:35Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgbase="sqlite3"
+pkgname=('sqlite3' 'sqlite3-tcl')
+_amalgamationver=3071100
+_amalgamationver2=${_amalgamationver/00/}
+#pkgver=${_amalgamationver2//0/.}
+pkgver=3.7.11
+pkgrel=1
+pkgdesc="A C library that implements an SQL database engine"
+arch=('i686' 'x86_64' 'mips64el')
+license=('custom')
+url="http://www.sqlite.org/"
+makedepends=('tcl' 'readline>=6.0.00')
+source=( # tarball containing the amalgamation for SQLite 3.7.5 together with a configure script and makefile for building it; includes now also the Tcl Extension Architecture (TEA)
+ http://www.sqlite.org/sqlite-autoconf-$_amalgamationver.tar.gz
+ license.txt)
+options=('!libtool' '!emptydirs')
+md5sums=('0552d71bda98ebdcaea305cd6058221b'
+ 'c1cdbc5544034d9012e421e75a5e4890')
+
+build() {
+ export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE"
+
+ # build sqlite
+ cd "$srcdir"/sqlite-autoconf-$_amalgamationver
+ ./configure --prefix=/usr \
+ --disable-static
+ make
+
+ # build the tcl extension
+ cd "$srcdir"/sqlite-autoconf-$_amalgamationver/tea
+ ./configure --prefix=/usr \
+ --with-system-sqlite
+ make
+
+}
+
+package_sqlite3() {
+
+ pkgdesc="A C library that implements an SQL database engine"
+ depends=('readline>=6.0.00')
+ conflicts=('sqlite')
+ replaces=('sqlite')
+
+ cd ${srcdir}/sqlite-autoconf-$_amalgamationver
+ make DESTDIR=${pkgdir} install
+
+ # license
+ install -D -m644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_sqlite3-tcl() {
+
+ pkgdesc="sqlite3 Tcl Extension Architecture (TEA)"
+ depends=('sqlite3>=3.7.5')
+
+ cd ${srcdir}/sqlite-autoconf-$_amalgamationver/tea
+ make DESTDIR=${pkgdir} install
+}