summaryrefslogtreecommitdiff
path: root/libre/texlive-bin-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-06-26 22:56:19 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-06-26 22:56:19 -0300
commit301eee81b736278d4c83fc3a5bb2fdf14e3d5801 (patch)
treeabecc4a144f42f4e087679e86c4af9f648ce59b8 /libre/texlive-bin-libre/PKGBUILD
parent54cec3f05fae381e28b14adc5f6dc1d2ae5350f5 (diff)
texlive-bin-libre-2012.0-1: updating version
Diffstat (limited to 'libre/texlive-bin-libre/PKGBUILD')
-rw-r--r--libre/texlive-bin-libre/PKGBUILD126
1 files changed, 42 insertions, 84 deletions
diff --git a/libre/texlive-bin-libre/PKGBUILD b/libre/texlive-bin-libre/PKGBUILD
index 31b440c9d..68c71284c 100644
--- a/libre/texlive-bin-libre/PKGBUILD
+++ b/libre/texlive-bin-libre/PKGBUILD
@@ -1,17 +1,16 @@
-# $Id: PKGBUILD 159191 2012-05-17 14:36:30Z remy $
+# $Id: PKGBUILD 162397 2012-06-26 20:13:46Z remy $
# Maintainer: Rémy Oudompheng <remy@archlinux.org>
# Contributor: francois <francois.archlinux.org>
# Maintainer (Parabola): Michał Masłowski <mtjm@mtjm.eu>
-# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Contributor (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=texlive-bin-libre
-pkgver=2011.3
-_luatex_ver=0.70.1
-pkgrel=7
+pkgver=2012.0
+pkgrel=1
pkgdesc="TeX Live binaries"
license=('GPL')
arch=('i686' 'x86_64' 'mips64el')
-depends=('t1lib' 'gd' 'poppler' 'libsigsegv' 'zziplib')
+depends=('t1lib' 'gd' 'poppler' 'libsigsegv' 'zziplib' 'libpng' 'libjpeg' 'freetype2')
makedepends=('perl' 'clisp' 'ffcall')
optdepends=('ed: for texconfig')
provides=('lcdf-typetools' 'kpathsea' 'xindy' 'pdfjam' 'texlive-bin')
@@ -23,11 +22,9 @@ install="texlive.install"
source=('texmf.cnf'
'fix-fontforge-encoding.patch'
'09-texlive-fonts.conf'
- 'luatex-poppler-0.20.patch'
- 'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20111210.tar.xz'
- 'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20111210.tar.xz'
- # "http://foundry.supelec.fr/gf/download/frsrelease/392/1730/luatex-beta-${_luatex_ver}.tar.bz2"
- 'http://ftp.archlinux.org/other/texlive/luatex-svn4356.tar.xz'
+ 'poppler-0.20.patch'
+ 'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20120623.tar.xz'
+ 'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20120623.tar.xz'
)
backup=(etc/texmf/web2c/texmf.cnf \
etc/texmf/chktex/chktexrc \
@@ -46,10 +43,9 @@ backup=(etc/texmf/web2c/texmf.cnf \
md5sums=('220a4f4cc0d915bf8fcbcb553dcee1ae'
'bfb9716aa00c86c08cd31e5b32edeb98'
'393a4bf67adc7ca5df2b386759d1a637'
- '52ce57c02e30a25036b6a3175c566b78'
- 'c7bb38c0ab30c2b64cf4cf83a736b35c'
- '5d8f06a3683ce88a3c33e15f5ba6a858'
- 'e7f0197559ef865d8c01683dab3b8526')
+ 'e3a664d5a7f0923f35060fe9d25d2573'
+ 'ac2c3c3aa765581f8504e21a5edbfb9f'
+ 'f315a860158cfc952c82a6d759961024')
build() {
if [ "${CARCH}" != "i686" ]; then
@@ -57,50 +53,11 @@ build() {
export CXXFLAGS="${CXXFLAGS} -fPIC"
fi
- cd "$srcdir"
- # Building LuaTeX
- # cd luatex-beta-${_luatex_ver}
- cd luatex
- patch -p0 -i ../fix-fontforge-encoding.patch
- patch -Np0 -i ../luatex-poppler-0.20.patch
- (cd source && ./texk/web2c/luatexdir/getluatexsvnversion.sh)
- mkdir build
- cd build
- ../source/configure --prefix=/usr -C \
- --disable-native-texlive-build \
- --with-banner-add="/Parabola GNU/Linux-libre" \
- --enable-cxx-runtime-hack \
- --disable-all-pkgs \
- --disable-dump-share \
- --disable-ptex \
- --enable-luatex \
- --without-system-ptexenc \
- --without-system-graphite \
- --without-system-icu \
- --without-system-kpathsea \
- --with-system-freetype2 \
- --with-system-poppler \
- --with-freetype2-libdir=/usr/lib \
- --with-freetype2-include=/usr/include/freetype2 \
- --with-system-gd \
- --with-system-libpng \
- --without-system-teckit \
- --with-system-zlib \
- --with-system-zziplib \
- --with-system-t1lib \
- --disable-shared \
- --disable-largefile \
- --disable-ipc \
- --without-mf-x-toolkit \
- --without-x
- make
- make -C libs/obsdcompat
- make -C texk/kpathsea
- make -C texk/web2c luatex
-
- cd "$srcdir"
+ cd "$srcdir"
# this patch removes spurious error message with locale "xx_YY.utf8"
- patch -p0 -i fix-fontforge-encoding.patch
+ patch -Np0 -i fix-fontforge-encoding.patch
+ # fix build with poppler >= 0.20
+ patch -Np0 -i poppler-0.20.patch
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
sed -i s/SELFAUTOPARENT/TEXMFROOT/ source/texk/tex4htk/t4ht.c
#############################################################
@@ -127,22 +84,22 @@ build() {
--disable-t1utils \
--disable-bibtexu \
--disable-xz \
- --without-system-zlib \
- --without-system-zziplib \
- --without-system-pnglib \
+ --with-system-zlib \
+ --with-system-zziplib \
+ --with-system-pnglib \
--with-system-ncurses \
--with-system-t1lib \
- --without-system-gd \
- --without-system-poppler \
- --without-system-xpdf \
- --without-system-freetype2 \
+ --with-system-gd \
+ --with-system-poppler \
+ --with-system-xpdf \
+ --with-system-freetype2 \
--without-system-graphite \
--with-freetype2-libdir=/usr/lib \
--with-freetype2-include=/usr/include/freetype2 \
--with-xdvi-x-toolkit=xaw \
--disable-dump-share \
--disable-aleph \
- --disable-luatex \
+ --enable-luatex \
--with-clisp-runtime=default \
--enable-xindy --disable-xindy-rules --disable-xindy-docs
#############################################################
@@ -238,13 +195,6 @@ package() {
## remove aleph from fmtutil.cnf
sed -i -e '/aleph/d' "$pkgdir"/usr/share/texmf/web2c/fmtutil.cnf
- ## install luatex binary
- #install -m755 "$srcdir"/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex "$pkgdir"/usr/bin/
- install -m755 "$srcdir"/luatex/build/texk/web2c/luatex "$pkgdir"/usr/bin/
- cd "$pkgdir"/usr/bin
- /bin/ln -s luatex texlua
- /bin/ln -s luatex texluac
-
## install Perl libraries
mkdir -p "$pkgdir"/usr/share/tlpkg/TeXLive
install -m644 "${srcdir}"/source/utils/biber/TeXLive/*.pm "$pkgdir"/usr/share/tlpkg/TeXLive
@@ -256,6 +206,7 @@ package() {
# remove dangling symlinks
_bibtexextra_scripts="
bibexport
+listbib
urlbst
"
_core_scripts="
@@ -263,6 +214,7 @@ afm2afm
arlatex
autoinst
bundledoc
+checkcites
cmap2enc
ctanify
ctanupload
@@ -277,6 +229,7 @@ installfont-tl
latex2man
latexdiff
latexdiff-vc
+latexfileversion
latexmk
latexrevise
listings-ext.sh
@@ -315,31 +268,36 @@ texdiff
texdirflatten
texliveonfly
texloganalyser
+typeoutfileinfo
thumbpdf
vpl2ovp
vpl2vpl
"
_htmlxml_scripts="ht htcontext htlatex htmex httex httexi htxelatex htxetex mk4ht"
+ _langcjk_scripts="convbkmk updmap-setup-kanji"
_langextra_scripts="ebong"
_langgreek_scripts="mkgrkindex"
- _latexextra_scripts="authorindex \
-makeglossaries \
-pdfannotextractor \
-pdfthumb \
-perltex \
-ppower4 \
-ps4pdf \
-splitindex \
-svn-multi \
+ _latexextra_scripts="
+authorindex
+exceltex
+exceltex
+makeglossaries
+pdfannotextractor
+perltex
+ppower4
+ps4pdf
+splitindex
+svn-multi
vpe"
- _music_scripts="musixtex musixflx"
+ _music_scripts="m-tx musixtex musixflx pmx2pdf"
_pictures_scripts="cachepic epspdf epspdftk fig4latex mathspic"
- _pstricks_scripts="pst2pdf"
+ _pstricks_scripts="pedigree pst2pdf"
_science_scripts="ulqda"
for s in \
${_bibtexextra_scripts} \
${_core_scripts} \
${_htmlxml_scripts} \
+ ${_langcjk_scripts} \
${_langextra_scripts} \
${_langgreek_scripts} \
${_latexextra_scripts} \