summaryrefslogtreecommitdiff
path: root/libre/texlive-bin/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-06-25 20:14:18 +0200
committerAndreas Grapentin <andreas@grapentin.org>2019-06-25 20:14:18 +0200
commit7e87b948b477d0887b61ed54e2ba9ba3aa77da7c (patch)
tree6fc334bb1f5e70dc1f909a3351642fc8270ca838 /libre/texlive-bin/PKGBUILD
parent4bd637effeb24a6492b6df5dca9f5ca03c2c396a (diff)
libre/texlive-bin: updated to 2019.51075
Diffstat (limited to 'libre/texlive-bin/PKGBUILD')
-rw-r--r--libre/texlive-bin/PKGBUILD66
1 files changed, 22 insertions, 44 deletions
diff --git a/libre/texlive-bin/PKGBUILD b/libre/texlive-bin/PKGBUILD
index 8af76c73f..0044860d3 100644
--- a/libre/texlive-bin/PKGBUILD
+++ b/libre/texlive-bin/PKGBUILD
@@ -12,61 +12,33 @@
# - diable xindy on armv7h
pkgname=('texlive-bin' 'libsynctex')
-pkgver=2018.48691
-pkgrel=10
-pkgrel+=.par2
+pkgver=2019.51075
+pkgrel=1
+pkgrel+=.par1
license=('GPL')
arch=('x86_64')
arch+=('i686' 'armv7h')
makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
'libsigsegv' 'zziplib' 'libpng' 'libjpeg' 'freetype2'
'icu' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
- 'perl' 'clisp' 'ffcall')
-makedepends_i686=('pkgconf')
+ 'perl')
+makedepends_x86_64=('clisp' 'ffcall')
+makedepends_i686=('clisp' 'ffcall')
url='http://tug.org/texlive/'
-_commit=f68b0992e13a2e155d71beb3e016ea4139023224 # texlive-2018.2
+_commit=74c2495978a4a84ffae10252c0fd244f1140228e # texlive-2019.2 r51075
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}"
- "pdftex-poppler0.76.patch"
- "luatex-poppler-fixes.patch"
- "xetex-poppler-fixes.patch"
- "freetype-pkgconfig.patch"
- "synctex-missing-header.patch")
+ "pdftex-poppler0.76.patch")
sha256sums=('SKIP'
- '0b4070f489edef771f308687d9e99cb54e8a442f0229767c6fda5515045cd797'
- '6daa9fb9991f34406a0620a7f9185776ce1ac601a9c66a537c4b90ce97c1ffc6'
- '7deb8bd50640b0f4ff9b4c11985fe6153906384b62cb9b5a3c4b52397fb941ca'
- 'bed44f4ccda369410e90eac527cf44b8c1afda7d987ae521b4fd5edb425eef3e'
- 'b6c81eb091b5910226e0359768edd178680debee56b63ab0a3753c3429c28ab0')
+ '5da9f5356ca14d950c222108b431baaf5c27667460ffab9597b29ef11b426c0f')
prepare() {
cd "$srcdir/texlive-source"
- # Synctex "make install" misses synctex_version.h
- patch -Np1 -i "${srcdir}/synctex-missing-header.patch"
-
- # Freetype2 2.9.1 package no longer has freetype-config
- patch -Np1 -i "${srcdir}/freetype-pkgconfig.patch"
-
- ./reautoconf
-
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
sed -i s/SELFAUTOPARENT/TEXMFROOT/ texk/tex4htk/t4ht.c
- # luatex switched from poppler to pplib in newer versions so
- # upstream fixes aren't available; hopefully this is correct
- patch -Np1 -i "${srcdir}/luatex-poppler-fixes.patch"
- find texk/web2c/luatexdir -type f -exec sed -i \
- -e 's|gTrue|true|g' \
- -e 's|gFalse|false|g' \
- -e 's|GBool|bool|g' \
- -e 's|getCString|c_str|g' \
- -e 's|Guint|unsigned int|g' \
- -e 's|Guchar|unsigned char|g' \
- {} +
- # xetex poppler compatibility
- patch -Np1 -i "${srcdir}/xetex-poppler-fixes.patch"
# pdftex poppler compatibility (upstream patches)
- patch -Np1 -i "${srcdir}/pdftex-poppler0.76.patch"
+ patch -Np1 -i "$srcdir/pdftex-poppler0.76.patch"
cp -pv texk/web2c/pdftexdir/pdftoepdf{-poppler0.76.0,}.cc
cp -pv texk/web2c/pdftexdir/pdftosrc{-poppler0.76.0,}.cc
}
@@ -74,11 +46,11 @@ prepare() {
build() {
cd "$srcdir/texlive-source"
- if [ "${CARCH}" = "armv7h" ]; then
- local config_xindy="--disable-xindy"
- else
- local config_xindy="--enable-xindy"
- fi
+ local config_extra=()
+ case "$CARCH" in
+ x86_64|i686) config_extra+=(--enable-xindy) ;;
+ armv7h) config_extra+=(--disable-xindy --disable-cxx-runtime-hack) ;;
+ esac
#############################################################
### configure
@@ -127,7 +99,8 @@ build() {
--disable-aleph \
--enable-luatex \
--with-clisp-runtime=default \
- $config_xindy --disable-xindy-rules --disable-xindy-docs
+ --disable-xindy-rules --disable-xindy-docs \
+ ${config_extra}
#############################################################
### make
echo "-------------------------------------------------------"
@@ -240,8 +213,10 @@ checkcites
checklistings
chkweb
cjk-gs-integrate
+cluttex
context
contextjit
+ctanbib
ctanify
ctanupload
ctan-o-mat
@@ -322,6 +297,7 @@ pdfjoin
pdflatexpicscale
pdfnup
pdfpun
+pdftex-quiet
pdfxup
pfarrei
pkfix
@@ -367,6 +343,7 @@ updmap-user
vpl2ovp
vpl2vpl
xhlatex
+xindex
xindy
"
if [ "$CARCH" = "armv7h" ]; then
@@ -397,6 +374,7 @@ ps4pdf
splitindex
svn-multi
vpe
+webquiz
wordcount
yplan"
_music_scripts="lily-glyph-commands lily-image-commands lily-rebuild-pdfs