summaryrefslogtreecommitdiff
path: root/libre/texlive-bin/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-05-04 10:19:02 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2020-05-04 10:53:53 -0400
commitd881ae5096fe407ab3af04f275041aee7589b7f1 (patch)
tree0cccdb9b99614f1707f13e0a7594e4c4a84a4261 /libre/texlive-bin/PKGBUILD
parent6d2b9390bd29f95d418b95955d12e3ec0b01008d (diff)
[texlive-bin]: upgrade to v2020.54586
Diffstat (limited to 'libre/texlive-bin/PKGBUILD')
-rw-r--r--libre/texlive-bin/PKGBUILD138
1 files changed, 59 insertions, 79 deletions
diff --git a/libre/texlive-bin/PKGBUILD b/libre/texlive-bin/PKGBUILD
index 55af528ac..938e5022b 100644
--- a/libre/texlive-bin/PKGBUILD
+++ b/libre/texlive-bin/PKGBUILD
@@ -12,27 +12,22 @@
# - diable xindy on armv7h
pkgname=('texlive-bin' 'libsynctex')
-pkgver=2019.51075
-pkgrel=8
-pkgrel+=.par1
+pkgver=2020.54586
+pkgrel=1
+pkgrel+=.parabola1
license=('GPL')
arch=('x86_64')
arch+=('i686' 'armv7h')
makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
'libsigsegv' 'zziplib' 'libpng' 'libjpeg' 'freetype2'
- 'icu' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
+ 'icu-parabola' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
'perl')
makedepends_x86_64=('clisp' 'ffcall')
makedepends_i686=('clisp' 'ffcall')
url='https://tug.org/texlive/'
-_commit=74c2495978a4a84ffae10252c0fd244f1140228e # texlive-2019.2 r51075
-source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}"
- "pdftex-poppler0.76.patch" texlive-poppler-0.83.patch texlive-poppler-0.84.patch texlive-poppler-0.86.patch)
-sha256sums=('SKIP'
- '5da9f5356ca14d950c222108b431baaf5c27667460ffab9597b29ef11b426c0f'
- 'ae68858b3ed60f6ef49cf29f31f601d0660908551484afe86283bc6054e9d9f8'
- '4a4ff82c85cecafc5bbf544e568d80022e9456c3223648fa8d64e699526646c5'
- '3438c1a3b7e1422ca964819b5cdf9ece086881c6448d0e2e3cfffdc1b082bb5d')
+_commit=8e5e0e89d413d09cca133c8966d1a3af8a2ac440 # svn://tug.org/texlive/trunk/Build/source@54586
+source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}")
+sha256sums=('SKIP')
prepare() {
cd "$srcdir/texlive-source"
@@ -40,25 +35,14 @@ prepare() {
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
sed -i s/SELFAUTOPARENT/TEXMFROOT/ texk/tex4htk/t4ht.c
- # pdftex poppler compatibility (upstream patches)
- patch -Np1 -i "$srcdir/pdftex-poppler0.76.patch"
- cp -pv texk/web2c/pdftexdir/pdftoepdf{-poppler0.76.0,}.cc
- cp -pv texk/web2c/pdftexdir/pdftosrc{-poppler0.76.0,}.cc
-
- patch -p1 -i ../texlive-poppler-0.83.patch
- patch -p1 -i ../texlive-poppler-0.84.patch # Gentoo patch
- patch -p1 -i ../texlive-poppler-0.86.patch
+ # pdftex poppler compatibility
+ cp -pv texk/web2c/pdftexdir/pdftoepdf{-poppler0.86.0,}.cc
+ cp -pv texk/web2c/pdftexdir/pdftosrc{-poppler0.83.0,}.cc
}
build() {
cd "$srcdir/texlive-source"
- local config_extra=()
- case "$CARCH" in
- x86_64|i686) config_extra+=(--enable-xindy) ;;
- armv7h) config_extra+=(--disable-xindy --disable-cxx-runtime-hack) ;;
- esac
-
#############################################################
### configure
mkdir -p Work
@@ -106,8 +90,10 @@ build() {
--disable-aleph \
--enable-luatex \
--with-clisp-runtime=default \
- --disable-xindy-rules --disable-xindy-docs \
- ${config_extra}
+ $(case "$CARCH" in
+ x86_64|i686) echo '--enable-xindy --disable-xindy-rules --disable-xindy-docs' ;;
+ armv7h ) echo '--disable-xindy --disable-cxx-runtime-hack' ;;
+ esac)
#############################################################
### make
echo "-------------------------------------------------------"
@@ -137,12 +123,11 @@ package_texlive-bin() {
'biber: for bibliography processing')
options=('!strip')
- local _icu_ver
- _icu_ver=$(pacman -S --print-format='%v' icu)
- depends+=("icu>=${_icu_ver}" "icu<$((${_icu_ver%%.*} + 1))")
- local _poppler_ver
- _poppler_ver=$(pacman -S --print-format='%v' poppler)
- depends+=("poppler=${_poppler_ver}")
+ # pin to current 'icu' and 'poppler' libs
+ local _icu_ver=$( pacman -S --print-format='%v' icu-parabola)
+ local _poppler_ver=$(pacman -S --print-format='%v' poppler )
+ depends+=("icu-parabola>=${_icu_ver}" "icu-parabola<$(( ${_icu_ver%%.*} + 1 ))"
+ "poppler=${_poppler_ver}" )
cd "$srcdir/texlive-source"
@@ -159,34 +144,34 @@ package_texlive-bin() {
rm -rf "${pkgdir}"/usr/{texmf,share/texmf-dist}
## symlink engines by hand. texlinks has moved to texlive-core...
- mkdir -p ${pkgdir}/usr/bin
- ln -s eptex ${pkgdir}/usr/bin/platex
- ln -s euptex ${pkgdir}/usr/bin/uplatex
- ln -s luatex ${pkgdir}/usr/bin/dvilualatex
- ln -s luatex ${pkgdir}/usr/bin/dviluatex
- ln -s luatex ${pkgdir}/usr/bin/lualatex
- ln -s pdftex ${pkgdir}/usr/bin/amstex
- ln -s pdftex ${pkgdir}/usr/bin/cslatex
- ln -s pdftex ${pkgdir}/usr/bin/csplain
- ln -s pdftex ${pkgdir}/usr/bin/eplain
- ln -s pdftex ${pkgdir}/usr/bin/etex
- ln -s pdftex ${pkgdir}/usr/bin/jadetex
- ln -s pdftex ${pkgdir}/usr/bin/latex
- ln -s tex ${pkgdir}/usr/bin/lollipop
- ln -s pdftex ${pkgdir}/usr/bin/mex
- ln -s pdftex ${pkgdir}/usr/bin/mllatex
- ln -s pdftex ${pkgdir}/usr/bin/mltex
- ln -s pdftex ${pkgdir}/usr/bin/pdfetex
- ln -s pdftex ${pkgdir}/usr/bin/pdfcslatex
- ln -s pdftex ${pkgdir}/usr/bin/pdfcsplain
- ln -s pdftex ${pkgdir}/usr/bin/pdfjadetex
- ln -s pdftex ${pkgdir}/usr/bin/pdflatex
- ln -s pdftex ${pkgdir}/usr/bin/pdfmex
- ln -s pdftex ${pkgdir}/usr/bin/pdfxmltex
- ln -s pdftex ${pkgdir}/usr/bin/texsis
- ln -s pdftex ${pkgdir}/usr/bin/utf8mex
- ln -s pdftex ${pkgdir}/usr/bin/xmltex
- ln -s xetex ${pkgdir}/usr/bin/xelatex
+ mkdir -p "${pkgdir}"/usr/bin
+ ln -s eptex "${pkgdir}"/usr/bin/platex
+ ln -s euptex "${pkgdir}"/usr/bin/uplatex
+ ln -s luatex "${pkgdir}"/usr/bin/dvilualatex
+ ln -s luatex "${pkgdir}"/usr/bin/dviluatex
+ ln -s luahbtex "${pkgdir}"/usr/bin/lualatex
+ ln -s pdftex "${pkgdir}"/usr/bin/amstex
+ ln -s pdftex "${pkgdir}"/usr/bin/cslatex
+ ln -s pdftex "${pkgdir}"/usr/bin/csplain
+ ln -s pdftex "${pkgdir}"/usr/bin/eplain
+ ln -s pdftex "${pkgdir}"/usr/bin/etex
+ ln -s pdftex "${pkgdir}"/usr/bin/jadetex
+ ln -s pdftex "${pkgdir}"/usr/bin/latex
+ ln -s tex "${pkgdir}"/usr/bin/lollipop
+ ln -s pdftex "${pkgdir}"/usr/bin/mex
+ ln -s pdftex "${pkgdir}"/usr/bin/mllatex
+ ln -s pdftex "${pkgdir}"/usr/bin/mltex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfetex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfcslatex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfcsplain
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfjadetex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdflatex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfmex
+ ln -s pdftex "${pkgdir}"/usr/bin/pdfxmltex
+ ln -s pdftex "${pkgdir}"/usr/bin/texsis
+ ln -s pdftex "${pkgdir}"/usr/bin/utf8mex
+ ln -s pdftex "${pkgdir}"/usr/bin/xmltex
+ ln -s xetex "${pkgdir}"/usr/bin/xelatex
#############################################################
# remove dangling symlinks
@@ -218,9 +203,12 @@ autoinst
bundledoc
checkcites
checklistings
+chklref
chkweb
cjk-gs-integrate
cluttex
+cllualatex
+clxelatex
context
contextjit
ctanbib
@@ -254,6 +242,7 @@ htxelatex
htxetex
installfont-tl
jfmutil
+ketcindy
kpsepath
kpsetool
kpsewhere
@@ -273,7 +262,6 @@ latexrevise
listings-ext.sh
ltxfileinfo
ltximg
-lua2dox_filter
luaotfload-tool
luatools
lwarpmk
@@ -284,26 +272,20 @@ mk4ht
mkjobtexmf
mkt1font
mktexfmt
+mktexlsr
+mktexmf
+mktexpk
+mktextfm
mptopdf
mtxrun
mtxrunjit
ot2kpx
-pdf180
-pdf270
-pdf90
+pamphletangler
pdfatfi
-pdfbook
pdfbook2
pdfcrop
-pdfflip
pdfjam
-pdfjam-pocketmod
-pdfjam-slides3up
-pdfjam-slides6up
-pdfjoin
pdflatexpicscale
-pdfnup
-pdfpun
pdftex-quiet
pdfxup
pfarrei
@@ -332,6 +314,7 @@ texdoc
texdoctk
texexec
texfot
+texhash
texindy
texlinks
texliveonfly
@@ -340,6 +323,7 @@ texmfstart
texosquery
texosquery-jre5
texosquery-jre8
+texplate
thumbpdf
tlcockpit
tlshell
@@ -351,11 +335,8 @@ vpl2ovp
vpl2vpl
xhlatex
xindex
-xindy
+$( [[ "$CARCH" != "armv7h" ]] && echo 'xindy')
"
- if [ "$CARCH" = "armv7h" ]; then
- _core_scripts="$(echo "$_core_scripts" | sed '/xindy$/d')"
- fi
_games_scripts="rubikrotation"
_humanities_scripts="diadia"
_langcyrillic_scripts="rubibtex rumakeindex"
@@ -424,4 +405,3 @@ pn2pdf"
rm -f "$pkgdir"/usr/lib/pkgconfig/synctex.pc
rm -f "$pkgdir"/usr/share/man/man*/synctex.*
}
-