summaryrefslogtreecommitdiff
path: root/libre/tp_smapi/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-01-15 04:21:04 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-01-15 04:21:04 -0500
commit031a4b4b56bac1acc07dbae3016316ae7bdd8e83 (patch)
treeb1783703b408b43e0056d8eec8b9ed941af12fd6 /libre/tp_smapi/PKGBUILD
parentac1f846127b923bb56b1c51207a8c0ac1a5d96c3 (diff)
rebuild module packages against linux-libre-4.14.12_gnu-1
Diffstat (limited to 'libre/tp_smapi/PKGBUILD')
-rw-r--r--libre/tp_smapi/PKGBUILD42
1 files changed, 15 insertions, 27 deletions
diff --git a/libre/tp_smapi/PKGBUILD b/libre/tp_smapi/PKGBUILD
index d3b431bce..475525ac2 100644
--- a/libre/tp_smapi/PKGBUILD
+++ b/libre/tp_smapi/PKGBUILD
@@ -11,46 +11,34 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
-_kernelname=
+_basekernel=4.14
+_archrel=45
+_parabolarel=2
-if [[ ${_kernelname} == "" ]]; then
- _basekernel=4.14
- _archrel=45
- _parabolarel=1
-elif [[ ${_kernelname} == -lts ]]; then
- _basekernel=4.9
- _archrel=24
- _parabolarel=1
-fi
-
-__pkgname=tp-smapi
-_pkgname=tp_smapi
-pkgname=${_pkgname}${_kernelname}
+pkgname=tp_smapi
+_pkgname=tp-smapi
pkgver=0.42
pkgrel=${_archrel}.parabola${_parabolarel}.basekernel${_basekernel}
-_extramodules=extramodules-${_basekernel}${_kernelname}
-pkgdesc="Modules for ThinkPad's SMAPI functionality (built for the linux-libre${_kernelname} kernel package)"
+_extramodules=extramodules-${_basekernel}
+pkgdesc="Modules for ThinkPad's SMAPI functionality (built for the linux-libre kernel package)"
arch=('i686' 'x86_64')
url='https://github.com/evgeni/tp_smapi'
license=('GPL')
# Generic (you shouldn't have to modify any of these variables)
_toohigh=$(IFS=. read a b <<<$_basekernel; echo $a.$((b+1)))
-depends=("linux-libre${_kernelname}>=${_basekernel}" "linux-libre${_kernelname}<${_toohigh}")
-makedepends=("linux-libre${_kernelname}-headers>=${_basekernel}" "linux-libre${_kernelname}-headers<${_toohigh}")
+depends=("linux-libre>=${_basekernel}" "linux-libre<${_toohigh}")
+makedepends=("linux-libre-headers>=${_basekernel}" "linux-libre-headers<${_toohigh}")
makedepends+=('libelf')
-replaces=("${_pkgname}-libre${_kernelname}" "${_pkgname}-parabola${_kernelname}")
-conflicts=("${_pkgname}-libre${_kernelname}" "${_pkgname}-parabola${_kernelname}")
-if [[ ${_kernelname} != "" ]]; then
- provides=("${_pkgname}")
-fi
+replaces=("${pkgname}-libre" "${pkgname}-parabola")
+conflicts=("${pkgname}-libre" "${pkgname}-parabola")
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/evgeni/${_pkgname}/archive/${__pkgname}/${pkgver}.tar.gz")
+source=("${pkgname}-${_pkgname}-${pkgver}.tar.gz::https://github.com/evgeni/${pkgname}/archive/${_pkgname}/${pkgver}.tar.gz")
sha256sums=('cd28bf6ee21b2c27b88d947cb0bfcb19648c7daa5d350115403dbcad05849381')
build() {
- cd "${_pkgname}-${__pkgname}-${pkgver}"
+ cd "${pkgname}-${_pkgname}-${pkgver}"
# https://bugs.archlinux.org/task/54975 (kernel has no _GLOBAL_OFFSET_TABLE_):
# Clear EXTRA_CFLAGS since it defaults to injecting CFLAGS and -fno-plt breaks the modules
@@ -59,7 +47,7 @@ build() {
}
package() {
- cd "${_pkgname}-${__pkgname}-${pkgver}"
+ cd "${pkgname}-${_pkgname}-${pkgver}"
# install kernel modules
find . -name "*.ko" -exec install -Dt "${pkgdir}/usr/lib/modules/${_extramodules}" {} +
@@ -69,5 +57,5 @@ package() {
# load module on startup
install -dm 755 "${pkgdir}/usr/lib/modules-load.d"
- echo ${_pkgname} > "${pkgdir}/usr/lib/modules-load.d/${_pkgname}${_kernelname}.conf"
+ echo ${pkgname} > "${pkgdir}/usr/lib/modules-load.d/${pkgname}.conf"
}