summaryrefslogtreecommitdiff
path: root/libre/unzip-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-14 17:33:46 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-14 17:33:46 -0200
commit16cd4e86a10dfd9728f2bed0650b1650e3676742 (patch)
tree3deb3fa0984b5a59287961cb5d4cb6e031e89769 /libre/unzip-libre/PKGBUILD
parentc48de4b1511c7ec182dbd3b187257f51b8729843 (diff)
unzip-libre-6.0-6: updating revision
Diffstat (limited to 'libre/unzip-libre/PKGBUILD')
-rw-r--r--libre/unzip-libre/PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/libre/unzip-libre/PKGBUILD b/libre/unzip-libre/PKGBUILD
index 20c3885f9..6b216573e 100644
--- a/libre/unzip-libre/PKGBUILD
+++ b/libre/unzip-libre/PKGBUILD
@@ -1,36 +1,42 @@
-# $Id: PKGBUILD 70615 2010-02-27 15:46:11Z thayer $
-# Maintainer: Thayer Williams <thayer@archlinux.org>
+# $Id: PKGBUILD 150452 2012-02-17 23:21:23Z allan $
+# Maintainer:
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: Robson Peixoto
_pkgname=unzip
pkgname=unzip-libre
pkgver=6.0
-pkgrel=5
+pkgrel=6
pkgdesc="Unpacks .zip archives such as those made by PKZIP"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://www.info-zip.org/"
license=('custom')
depends=('bzip2' 'bash')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
replaces=("${_pkgname}")
-source=("https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${pkgrel}-any.src.tar.xz")
-
+source=('http://downloads.sourceforge.net/infozip/unzip60.tar.gz'
+ 'match.patch')
+md5sums=('8e8a774e2006617d8787d095bb78c78a'
+ 'e6d9f0c204c2abe6a57dc5e1637d5140')
build() {
cd ${srcdir}/${_pkgname}${pkgver/./}
+ # from http://bzr.trisquel.info/package-helpers/trunk/annotate/head%3A/helpers/natty/DATA/unzip/match.patch
+ patch -Np0 -i ${srcdir}/match.patch
+
# set CFLAGS -- from Debian
export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -DACORN_FTYPE_NFS \
-DWILD_STOP_AT_DIR -DLARGE_FILE_SUPPORT -DUNICODE_SUPPORT \
-DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DNO_LCHMOD -DDATE_FORMAT=DF_YMD \
-DUSE_BZIP2 -DNATIVE"
+ sed -i "/MANDIR =/s#)/#)/share/#" unix/Makefile
+
# make -- from Debian
make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr LF2="" \
D_USE_BZ2=-DUSE_BZIP2 L_BZ2=-lbz2 unzips
-
}
package(){
@@ -41,10 +47,5 @@ package(){
# install the license file
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/unzip/LICENSE
-
- # fix manpage location
- mkdir -p ${pkgdir}/usr/share
- mv ${pkgdir}/usr/man ${pkgdir}/usr/share/
}
-md5sums=('8e8a774e2006617d8787d095bb78c78a')