summaryrefslogtreecommitdiff
path: root/libre/unzip/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-01-10 23:45:32 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-01-10 23:45:32 -0200
commit0bb4e9837efe653fbac32b6a444e6cb58351114c (patch)
tree7d613da8ce0569845278a766c80eb570057ee37a /libre/unzip/PKGBUILD
parent01849a148f7c2485d7eaf6d5da7077f336e36446 (diff)
unzip-6.0-9.parabola1: fix FS#43391 -> https://bugs.archlinux.org/task/43391
Diffstat (limited to 'libre/unzip/PKGBUILD')
-rw-r--r--libre/unzip/PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/libre/unzip/PKGBUILD b/libre/unzip/PKGBUILD
index adbf9b116..24915ae62 100644
--- a/libre/unzip/PKGBUILD
+++ b/libre/unzip/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 228865 2015-01-09 19:38:36Z bisson $
+# $Id: PKGBUILD 228890 2015-01-10 19:27:10Z bisson $
# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
# Contributor (Arch): Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor (Arch): Robson Peixoto
@@ -7,7 +7,7 @@ _pkgname=unzip-libre
pkgname=unzip
pkgver=6.0
_pkgver=${pkgver/./}
-pkgrel=8.parabola1
+pkgrel=9.parabola1
pkgdesc='For extracting and viewing files in .zip archives'
url='http://www.info-zip.org/UnZip.html'
arch=('i686' 'x86_64' 'mips64el')
@@ -18,11 +18,13 @@ replaces=("${_pkgname}")
mksource=("http://downloads.sourceforge.net/infozip/${pkgname}${_pkgver}.tar.gz"
'match.patch')
source=("https://repo.parabola.nu/other/${_pkgname}/${pkgname}${_pkgver}-libre.tar.gz"
+ 'test_compr_eb.patch'
'getZip64Data.patch'
'crc32.patch')
mksha1sums=('abf7de8a4018a983590ed6f5cbd990d4740f8a22'
'63bb2bb8483088d5975ce17443dd31b0362c08c9')
sha1sums=('80808a3b520f8b73ee3a4dc4b5c29411cba43aa2'
+ '614c3e7fa7d6da7c60ea2aa79e36f4cbd17c3824'
'691d0751bf0bc98cf9f9889dee39baccabefdc4d'
'82c9fe9172779a0ee92a187d544e74e8f512b013')
@@ -36,6 +38,7 @@ mksource() {
prepare() {
cd "${srcdir}/${pkgname}${_pkgver}"
sed -i "/MANDIR =/s#)/#)/share/#" unix/Makefile
+ patch -i ../test_compr_eb.patch # FS#43391
patch -i ../getZip64Data.patch # FS#43300
patch -i ../crc32.patch # FS#43300
}