summaryrefslogtreecommitdiff
path: root/libre/wings3d/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-11-14 12:56:40 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-11-14 12:56:40 -0200
commit95070ab67ef91fe05b9df0e0100d8cd80e489d83 (patch)
treef1de2b934a71f0326cc06d1930cd9d6d3e9f0e2d /libre/wings3d/PKGBUILD
parent9c77860f727872f5e5b5023fcfc4fdc146c2cb25 (diff)
wings3d-1.5.3-2.parabola1: updating revision from Arch
Diffstat (limited to 'libre/wings3d/PKGBUILD')
-rw-r--r--libre/wings3d/PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/libre/wings3d/PKGBUILD b/libre/wings3d/PKGBUILD
index 1690b4ba5..24b1966ea 100644
--- a/libre/wings3d/PKGBUILD
+++ b/libre/wings3d/PKGBUILD
@@ -1,48 +1,47 @@
-# $Id: PKGBUILD 113127 2014-06-13 22:30:55Z arodseth $
+# $Id: PKGBUILD 122569 2014-11-14 13:43:53Z arodseth $
# Maintainer (Arch): Alexander Rødseth <rodseth@gmail.com>
# Contributor (Arch): kappa <kappacurve@gmail.com>
# Maintainer: Márcio Silva <coadde@parabola.nu>
-_name=wings
pkgname=wings3d
+_pkgname=wings
pkgver=1.5.3
-pkgrel=1.parabola1
+pkgrel=2.parabola1
pkgdesc='3D modeling program, without nonfree kerkythea render support'
arch=('x86_64' 'i686' 'mips64el')
url='http://www.wings3d.com/'
license=('GPL')
depends=('erlang-sdl' 'erlang-cl' 'bash' 'desktop-file-utils' 'erlang')
-makedepends=('gendesk')
+makedepends=('gendesk' 'imagemagick')
optdepends=('povray: rendering support via POV-Ray')
conflicts=("${pkgname}-libre")
replaces=("${pkgname}-libre")
install=$pkgname.install
source=("http://downloads.sourceforge.net/project/wings/wings/$pkgver/wings-$pkgver.tar.bz2"
- "$pkgname.sh"
- "$pkgname.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png")
+ "$pkgname.sh")
sha256sums=('c08060016f83679ce08947942d31af0e3b5d105525d0df5e993ec6f1a81fdd8e'
- '46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e'
- '6658977cc3bc8db2c9358edf3a2d6cb6bb8084c9a1d96ca573a83dd4e8781f1a')
+ '46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e')
prepare() {
- gendesk -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name 'Wings3D' \
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name 'Wings3D' \
--genericname '3D Modeler' --categories 'Graphics;3DGraphics'
+ convert "$_pkgname-$pkgver/win32/wings.ico" "$pkgname.png"
}
build() {
export ESDL_PATH=$(echo /usr/lib/erlang/lib/esdl-*)
- make -C "$_name-$pkgver" all lang
+ make -C "$_pkgname-$pkgver" all lang
}
package() {
- install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$pkgname-3.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" \
"$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
- cd "$_name-$pkgver"
+ cd "$_pkgname-$pkgver"
install -d "$pkgdir/usr/lib/$pkgname"
for subdir in ebin fonts patches plugins shaders textures; do
- cp -r "$srcdir/$_name-$pkgver/$subdir/" "$pkgdir/usr/lib/$pkgname"
+ cp -r "$srcdir/$_pkgname-$pkgver/$subdir/" "$pkgdir/usr/lib/$pkgname"
done
msg 'remove nonfree kerkythea render support plugin'
rm -v $pkgdir/usr/lib/$pkgname/plugins/import_export/wpc_kerky.beam