summaryrefslogtreecommitdiff
path: root/libre/xchat-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-02 12:42:20 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-02 12:42:20 -0300
commitc7fb23005fe7fcc9a49b93831b499d70cf11a9b6 (patch)
treeb4a6bf1b75f1f320e77dbb9b6961184d8fed2baf /libre/xchat-libre/PKGBUILD
parent7cedc872a3e32cf8ef71e3c01150bb0e62db2b5c (diff)
xchat-libre-2.8.8-10: updating release with new patches
Diffstat (limited to 'libre/xchat-libre/PKGBUILD')
-rw-r--r--libre/xchat-libre/PKGBUILD57
1 files changed, 35 insertions, 22 deletions
diff --git a/libre/xchat-libre/PKGBUILD b/libre/xchat-libre/PKGBUILD
index f04ec2f47..223eaff72 100644
--- a/libre/xchat-libre/PKGBUILD
+++ b/libre/xchat-libre/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Maintainer: Henry Jensen <hjensen@connochaetos.org>
+# $Id: PKGBUILD 159467 2012-05-24 17:52:29Z eric $
+# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
+# Maintainet (Parabola): André Silva <andre.paulista@adinet.com.uy>
-pkgbasename=xchat
+_pkgname=xchat
pkgname=xchat-libre
pkgver=2.8.8
-pkgrel=7
+pkgrel=10
pkgdesc="A GTK+ based IRC client without non-free browser reference"
arch=('i686' 'x86_64')
url="http://www.xchat.org/"
@@ -12,39 +14,50 @@ provides=("xchat=$pkgver")
replaces=('xchat')
conflicts=('xchat')
license=('GPL')
-depends=('gtk2' 'openssl' 'dbus-glib' 'libnotify')
-makedepends=('tcl' 'perl' 'python2')
+depends=('gtk2' 'openssl' 'dbus-glib' 'libnotify' 'hicolor-icon-theme')
+makedepends=('tcl' 'perl' 'python2' 'librsvg')
optdepends=('enchant: for spell checking support' 'tcl: for tcl plugin'
'python2: for python plugin')
options=('!libtool')
-changelog=ChangeLog
-source=(http://www.xchat.org/files/source/${pkgver%.*}/${pkgbasename}-${pkgver}.tar.xz
+install=xchat.install
+source=(http://www.xchat.org/files/source/${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz
+ http://xchat.org/files/icons/xchat-svg.tar.bz2
xchat-2.8.8-libnotify07.patch
xchat-2.8.8-link-against-libnotify.patch
+ xchat-2.8.8-glib-2.31.patch
remove-non-free-suggestion.patch
no-firefox.patch)
+sha1sums=('e12305da42d1aacc26c2ca25e239f393d4dd3532'
+ '0d366346cc11e0efb57fc2648fe423c94a3469bd'
+ 'a053fba4e1911d1ee6a8248fe19e344797920fe3'
+ '70c3cc29fc55ff35f701ef8ac23078b6e3761ce1'
+ 'aecaf6176a7cfd62555207b02f2793b360aa39da'
+ 'ead8947ae0033735803a0353e3b9d23f40fff990'
+ 'aae58e189481e336825f8b56bf6939d55b2e42f3')
build() {
- cd "${srcdir}/${pkgbasename}-${pkgver}"
- patch -Np1 -i ${srcdir}/remove-non-free-suggestion.patch
- patch -Np1 -i ${srcdir}/no-firefox.patch
- patch -Np1 -i ${srcdir}/xchat-2.8.8-libnotify07.patch
- patch -Np1 -i ${srcdir}/xchat-2.8.8-link-against-libnotify.patch
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/xchat-2.8.8-libnotify07.patch"
+ patch -p1 -i "${srcdir}/xchat-2.8.8-link-against-libnotify.patch"
+ patch -p1 -i "${srcdir}/xchat-2.8.8-glib-2.31.patch"
+ patch -p1 -i "${srcdir}/remove-non-free-suggestion.patch"
+ patch -p1 -i "${srcdir}/no-firefox.patch"
autoconf
autoheader
- ./configure --prefix=/usr --sysconfdir=/etc --enable-openssl --enable-dbus \
- --disable-textfe --enable-ipv6 --enable-shm --enable-spell=static
+ LIBS+="-lgmodule-2.0" ./configure --prefix=/usr --sysconfdir=/etc --datadir=/usr/share \
+ --enable-openssl --enable-dbus --disable-textfe --enable-ipv6 --enable-shm --enable-spell=static
make
}
package() {
- cd "${srcdir}/${pkgbasename}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
-}
-md5sums=('9a11f13121ff0af787bba3b014378e58'
- '8f0ba48dc3d151cd9b4fbef3255e8c95'
- '805893e0d8f7c9713d703f34b6bb4b89'
- 'd0968310982fa9e30d43dd43536b7387'
- 'ba11c3e889509d1b46307d6ebf74509c')
+ for i in 24 32 48 64 128 256 ; do
+ install -d "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps"
+ rsvg-convert -w $i -h $i -o "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/xchat.png" ../xchat-cloned.svg
+ done
+ install -D -m644 ../xchat-cloned.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/xchat.svg"
+ install -D -m644 ../xchat-used.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/xchat2.svg"
+}