summaryrefslogtreecommitdiff
path: root/nonprism/grilo-plugins/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 01:57:36 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 01:57:36 -0300
commit0be822175bb3cef0534b9a0597e84ae1ee6374ec (patch)
treec9a4fb91c61309280fd8201c7cb52789ce02a7c6 /nonprism/grilo-plugins/PKGBUILD
parent468e115b1432c745ce9ccf06d2fcca6b3cfb7227 (diff)
remove nonprism suffix and add complex pkgrel on nonprism packages
Diffstat (limited to 'nonprism/grilo-plugins/PKGBUILD')
-rw-r--r--nonprism/grilo-plugins/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/nonprism/grilo-plugins/PKGBUILD b/nonprism/grilo-plugins/PKGBUILD
new file mode 100644
index 000000000..64378c771
--- /dev/null
+++ b/nonprism/grilo-plugins/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 210323 2014-04-14 09:05:45Z jgc $
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=grilo-plugins
+pkgver=0.2.12
+pkgrel=2.nonprism1
+pkgdesc="Plugins for Grilo, without libgdata support and gnome-online-accounts recommendation"
+url="http://www.gnome.org"
+arch=(i686 x86_64)
+license=(LGPL)
+replaces=(${pkgname}-nonprism)
+conflicts=(${pkgname}-nonprism)
+depends=(grilo sqlite libgcrypt)
+makedepends=(gupnp-av gmime libtracker-sparql libdmapsharing
+ json-glib intltool avahi itstool libmediaart lua)
+optdepends=('gupnp-av: uPnP plugin'
+ 'gmime: Podcasts plugin'
+ 'tracker: Tracker plugin'
+ 'libdmapsharing: DMAP sharing plugin'
+ 'json-glib: TMDb plugin'
+ 'avahi: Freebox plugin'
+ 'libmediaart: local-metadata plugin'
+ 'lua: LUA factory plugin')
+options=('!emptydirs')
+groups=('gnome')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver:0:3}/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('15bed8a633c81b251920ab677d455433e641388f605277ca88e549cc89012b48')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static \
+ --enable-shoutcast --disable-pocket --enable-lua-factory
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}