summaryrefslogtreecommitdiff
path: root/pcr-testing/calamares/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2018-05-01 15:22:01 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2018-05-01 15:43:28 -0400
commite6b3692660018608429dda411f61de84367af4b6 (patch)
tree0e035139ef035e189c875a84eeb7e7a1e546cf7d /pcr-testing/calamares/PKGBUILD
parent07ec90f6ff9b48e32175e32fafe7a60e8e9d91e5 (diff)
[calamares]: upgrade to v3.1.9-parabola7
Diffstat (limited to 'pcr-testing/calamares/PKGBUILD')
-rw-r--r--pcr-testing/calamares/PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/pcr-testing/calamares/PKGBUILD b/pcr-testing/calamares/PKGBUILD
index 49f6fa5bb..86802bee9 100644
--- a/pcr-testing/calamares/PKGBUILD
+++ b/pcr-testing/calamares/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=calamares
pkgver=3.1.9
-pkgrel='parabola6.3'
+pkgrel='parabola7'
pkgdesc='Distribution-independent installer framework - Parabola edition'
arch=('i686' 'x86_64')
license=('GPL')
url="https://calamares.io/"
-_latest_version() { pacman -Si $1 | grep Version | cut -d ':' -f 2 | sed 's/\s//g' ; }
+_latest_version() { pacman -Si $1 | awk '$1=="Version"{print $3}' ; }
_build_couplings=("boost=$(_latest_version 'boost')")
_runtime_couplings=("boost-libs=$(_latest_version 'boost')"
"icu=$(_latest_version 'icu')"
@@ -22,18 +22,15 @@ depends=(${_runtime_couplings[@]} 'dmidecode' 'gptfdisk' 'hwinfo' 'kconfig' 'kco
'qt5ct' 'qt5-styleplugins' 'qt5-svg' 'yaml-cpp')
_git_tag="v${pkgver}-${pkgrel%%.*}"
-source=("https://notabug.org/bill-auger/calamares/archive/${_git_tag}.tar.gz"
- welcome-lxde.txt
- welcome-mate.txt)
-sha256sums=('1873371daf0b56fbd50e16768a9d3618b0a9078098a9895797cd86bca8199bf9'
- 'f4eac2d05a33daaf75e81b4240124dbbd98e662797335ab116501e92b20e9849'
- '6211c6a404fc1a9437d291603fe9990580561f1057463a1f414f3662ff798a24')
+_build_dir=${pkgname}-${_git_tag}/build
+source=(https://git.parabola.nu/${pkgname}.git/snapshot/${pkgname}-${_git_tag}.tar.gz)
+sha256sums=('f50ac0a4916acdec85befb86b55883652a9335ca1a2253abfe10144f82deed90')
build()
{
- mkdir -p ${srcdir}/calamares/build
- cd ${srcdir}/calamares/build
+ mkdir -p ${srcdir}/${_build_dir}
+ cd ${srcdir}/${_build_dir}
cmake -DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -45,11 +42,7 @@ build()
package()
{
- cd ${srcdir}/calamares/build
+ cd ${srcdir}/${_build_dir}
make DESTDIR=${pkgdir} install
-
- # ASSERT: one welcome-<DESKTOP>*.txt for each DESKTOP in calamares GS::DESKTOPS_KEY
- install -d ${pkgdir}/usr/share/calamares/welcome/
- cp ${srcdir}/welcome-*.txt ${pkgdir}/usr/share/calamares/welcome/
}