summaryrefslogtreecommitdiff
path: root/pcr-testing/python2-django-postorius/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2018-09-12 08:25:54 +0000
committerbill-auger <mr.j.spam.me@gmail.com>2018-09-30 04:27:49 -0400
commit60149d4be1633dd72cba35fcfc29bcf9f117e6fd (patch)
tree3b6c121600f41edbe42ccc971d130cf69197c7e7 /pcr-testing/python2-django-postorius/PKGBUILD
parent4e8a56f5ba2fb21332825f6f00cc84725a9268b2 (diff)
add 'mailman3'
Diffstat (limited to 'pcr-testing/python2-django-postorius/PKGBUILD')
-rw-r--r--pcr-testing/python2-django-postorius/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/pcr-testing/python2-django-postorius/PKGBUILD b/pcr-testing/python2-django-postorius/PKGBUILD
new file mode 100644
index 000000000..35c01a07b
--- /dev/null
+++ b/pcr-testing/python2-django-postorius/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python2-django-postorius')
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A Django app that provides a web user interface to access GNU Mailman"
+arch=(any)
+url=https://gitlab.com/mailman/postorius
+license=('LGPL')
+options=(!emptydirs)
+
+makedepends=('python2-setuptools')
+depends=('python2' 'python2-django-mailman3')
+
+_upstream_name='postorius'
+_release="${_upstream_name}-${pkgver}"
+source=(https://gitlab.com/mailman/${_upstream_name}/-/archive/${pkgver}/${_release}.tar.gz)
+sha256sums=('4299c883a7e1a5044436a3c57a19bf337bd95b4e1b89fe6c66982843622d464e')
+
+
+package()
+{
+ cd "$srcdir/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}