summaryrefslogtreecommitdiff
path: root/pcr/bbswitch-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2020-12-08 20:12:21 +0100
committerAndreas Grapentin <andreas@grapentin.org>2020-12-08 20:12:21 +0100
commitcfe7ead1e8edb4aeecf267010da9f0effcb28989 (patch)
treebe41ebd8f8358290f255c2261da0b7b18dc83df5 /pcr/bbswitch-lts/PKGBUILD
parentdf96ee4a70df70d029d6285be9c44113507b377a (diff)
libre/bbswitch, pcr/bbswitch-lts: rebuilt for new kernels
Diffstat (limited to 'pcr/bbswitch-lts/PKGBUILD')
-rw-r--r--pcr/bbswitch-lts/PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/pcr/bbswitch-lts/PKGBUILD b/pcr/bbswitch-lts/PKGBUILD
index dca761fd7..5ff915a6a 100644
--- a/pcr/bbswitch-lts/PKGBUILD
+++ b/pcr/bbswitch-lts/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=4.19.97-1
+_basekernel=5.4.78
pkgname=bbswitch-lts
pkgver=0.8
@@ -19,8 +19,17 @@ arch+=('i686')
url="http://github.com/Bumblebee-Project/bbswitch"
license=('GPL')
makedepends=(linux-libre-lts-headers=${_basekernel%-*} git libelf)
-source=("${pkgname%-*}-$pkgver.tar.gz::https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
-sha256sums=('76cabd3f734fb4fe6ebfe3ec9814138d0d6f47d47238521ecbd6a986b60d1477')
+source=("${pkgname%-*}-$pkgver.tar.gz::https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz"
+ 0001-proc_ops-struct.patch 0002-kernel-5.7.patch)
+sha512sums=('11ab163931feb6c0e202d04c4552b848e999fedea9990390c26b28abdb4a69081ccfb5a22d1e390cc274f1c0cfc9adedc719c5fece14738b17aaa93e28865b7c'
+ '993a2895c37ea213c105be668f794af54838d8015d6f561ee6bc7ce65583425515931c83c2487ab97c14454105f233f089e8bdc90ea5ed9576be767335f57ad1'
+ '2eeae463b2f83e7744ff1a769cb6186389e026fc78668e836525dfd16a56abfae01cfb150c9bb46af74ec42e87ebea91636118fe0c773e7eaa7ea671b25d2e04')
+
+prepare() {
+ cd ${pkgname%-*}-${pkgver}
+ patch -Np1 < ../0001-proc_ops-struct.patch
+ patch -Np1 < ../0002-kernel-5.7.patch
+}
build() {
cd ${pkgname%-*}-${pkgver}
@@ -33,6 +42,7 @@ package() {
cd ${pkgname%-*}-${pkgver}
_extradir="/usr/lib/modules/$(</usr/src/linux-libre-lts/version)/extramodules"
install -Dt "${pkgdir}${_extradir}" -m644 *.ko
+ find "${pkgdir}" -name '*.ko' -exec strip --strip-debug {} +
find "${pkgdir}" -name '*.ko' -exec xz {} +
}