summaryrefslogtreecommitdiff
path: root/pcr/culmus/PKGBUILD
diff options
context:
space:
mode:
authorAlon Ivtsan <alonivtsan@lavabit.com>2013-07-16 03:06:45 +0300
committerAlon Ivtsan <alonivtsan@lavabit.com>2013-07-16 03:06:45 +0300
commit54dcfb85d14c150b312cd932aed940c19bb05251 (patch)
tree49f5e8e603ca7feae4dd8dbe71b73d2c78923595 /pcr/culmus/PKGBUILD
parentde25031b9839f64f7e41de83596015dec806aeb7 (diff)
Adding culmus, patch and install file
Diffstat (limited to 'pcr/culmus/PKGBUILD')
-rw-r--r--pcr/culmus/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/pcr/culmus/PKGBUILD b/pcr/culmus/PKGBUILD
new file mode 100644
index 000000000..e7efc2adc
--- /dev/null
+++ b/pcr/culmus/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer (Arch): Ivan Puntiy <ivan.puntiy at gmail>
+# Contributor (Arch): <francois.archlinux.org>
+# Maintainer (Parabola): Alon Ivtsan <alonivtsan@gmail.com>
+# taken from https://aur.archlinux.org/packages/culmus/
+
+pkgname=culmus
+pkgver=0.130
+pkgrel=1
+pkgdesc="A collection of Type1 and TrueType Hebrew fonts"
+arch=('any')
+url="http://culmus.sourceforge.net"
+license=('GPL2')
+depends=('fontconfig' 'xorg-fonts-alias' 'xorg-font-utils' 'xorg-fonts-encodings')
+install=${pkgname}.install
+source=(
+ "http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "$pkgname-0.121-fontconfig_fix.patch"
+)
+md5sums=('58e672defde4caeae42017cd2f9436a6'
+ '6db715a072d9602a54c69a7e31a6428f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fix due to fontconfig 2.10.1 update - patch mailed to upstream
+ patch culmus.conf "$srcdir/$pkgname-0.121-fontconfig_fix.patch"
+}
+
+package() {
+ # install Type1 fonts
+ install -d ${pkgdir}/usr/share/fonts/Type1
+ install -m644 ${srcdir}/culmus-$pkgver/*.{afm,pfa} \
+ ${pkgdir}/usr/share/fonts/Type1
+
+ # install ttf fonts
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -m644 ${srcdir}/culmus-$pkgver/*.ttf \
+ ${pkgdir}/usr/share/fonts/TTF
+
+ # install provided config file with priority 61
+ install -d ${pkgdir}/etc/fonts/conf.avail/
+ install -m644 ${srcdir}/culmus-$pkgver/culmus.conf \
+ ${pkgdir}/etc/fonts/conf.avail/61-culmus.conf
+}