summaryrefslogtreecommitdiff
path: root/pcr/econnman/PKGBUILD
diff options
context:
space:
mode:
authorAlon Ivtsan <alonivtsan@lavabit.com>2013-08-17 08:37:39 +0300
committerAlon Ivtsan <alonivtsan@lavabit.com>2013-08-17 08:37:39 +0300
commit0ffbcf0172c22c6492a99fa1223e96c677064bda (patch)
tree80d14602d33d1e337f5598a3a01ab55a99a1c70a /pcr/econnman/PKGBUILD
parentc014fe3d47320198b8abc94f588a642d950040a2 (diff)
adding econnman PKGBUILD to pcr
Diffstat (limited to 'pcr/econnman/PKGBUILD')
-rw-r--r--pcr/econnman/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/econnman/PKGBUILD b/pcr/econnman/PKGBUILD
new file mode 100644
index 000000000..a6419abc0
--- /dev/null
+++ b/pcr/econnman/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Doug Newgard <scimmia22 at outlook dot com>
+
+pkgname=econnman
+pkgver=1
+pkgrel=1
+pkgdesc="Enlightenment ConnMan user interface"
+arch=('any')
+url="http://www.enlightenment.org"
+license=('LGPL3')
+depends=('python2-elementary' 'python2-e_dbus' 'python2-edje' 'python2-ecore' 'connman')
+conflicts=('econnman-svn')
+source=("http://packages.profusion.mobi/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('cec2bd0aaf9d8975dd69ac6b5a4e638e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i 's:/usr/bin/python:/usr/bin/python2:g' econnman-bin.in
+
+ PYTHON=/usr/bin/python2 \
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+