summaryrefslogtreecommitdiff
path: root/pcr/emacs-dash/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:24:23 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:24:23 +0100
commit814f59cece8a3d6361a1dd236ce9a5ad02ac3980 (patch)
tree6662c354d7927638cb600c8c9380fdfc871743b1 /pcr/emacs-dash/PKGBUILD
parent3adab71e583103de1a9f5f663ff7d0bf33099a13 (diff)
pcr/emacs-dash: added
Diffstat (limited to 'pcr/emacs-dash/PKGBUILD')
-rw-r--r--pcr/emacs-dash/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/pcr/emacs-dash/PKGBUILD b/pcr/emacs-dash/PKGBUILD
new file mode 100644
index 000000000..7cd35e4d4
--- /dev/null
+++ b/pcr/emacs-dash/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor (AUR): ebiadsu
+# Previous Maintainer (AUR): holos
+# Contributor (AUR): Sebastien Duthil <duthils@free.fr>
+# Maintainer (AUR): Stefan Husmann <stefan-husmann@t-online.de>
+
+# parabola changes and rationale:
+# no changes.
+
+pkgname=emacs-dash
+pkgver=2.13.0
+pkgrel=2
+pkgdesc='A modern list API for Emacs'
+arch=('any')
+url="https://github.com/magnars/dash.el"
+license=('GPL')
+makedepends=('emacs')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/magnars/dash.el/archive/$pkgver.tar.gz")
+md5sums=('f246c9665345a6870820f8f9567c7c18')
+
+build() {
+ cd dash.el-"$pkgver"
+ emacs -Q -batch -L . -f batch-byte-compile dash{,-functional}.el
+}
+
+package() {
+ cd dash.el-"$pkgver"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/dash
+ install -Dm644 dash{,-functional}.{el,elc} \
+ "$pkgdir"/usr/share/emacs/site-lisp/dash
+ gzip "$pkgdir"/usr/share/emacs/site-lisp/dash/*.el
+ install -Dm644 dash.info "$pkgdir"/usr/share/info/dash.info
+}
+