summaryrefslogtreecommitdiff
path: root/pcr/emacs-org-mode/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-02-02 15:48:00 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-02-02 15:48:00 +0100
commitc5c30e1ff3ef01b3c440788b04eb9ed35b33a946 (patch)
tree7ae70542c06cee943efe0f5dcd7767e6b2e3b052 /pcr/emacs-org-mode/PKGBUILD
parenta8654f7e5c1d58ce8be8634c7071a50e0bcafcea (diff)
pcr/emacs-org-mode: updated to 9.0.5
Diffstat (limited to 'pcr/emacs-org-mode/PKGBUILD')
-rw-r--r--pcr/emacs-org-mode/PKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/pcr/emacs-org-mode/PKGBUILD b/pcr/emacs-org-mode/PKGBUILD
index ba0028fa4..717a174f7 100644
--- a/pcr/emacs-org-mode/PKGBUILD
+++ b/pcr/emacs-org-mode/PKGBUILD
@@ -1,38 +1,41 @@
-# Contributor (Arch): Jiyunatori <tori_LEAVETHISOUT_@0xc29.net>
-# Contributor (Arch): mdev
-# adopted by domanov <domanov_LEAVETHISOUT_@gmail.com>
+# Maintainer (AUR): Davor Balder <dbalder@ozemail.com.au>
+# Contributor (AUR): Jiyunatori <tori_LEAVETHISOUT_@0xc29.net>
+# Contributor (AUR): mdev
# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@hackers.camp>
+# parabola changes and rationale:
+# no changes.
+
pkgname=emacs-org-mode
_srcname=org
-pkgver=8.2.6
-pkgrel=1
+pkgver=9.0.5
+pkgrel=0
pkgdesc="Emacs Org Mode"
arch=('any')
url="http://orgmode.org/"
-depends=(emacs)
+depends=('emacs')
license=('GPL')
install=emacs-org-mode.install
-source=(http://orgmode.org/$_srcname-$pkgver.tar.gz)
+source=("http://orgmode.org/$_srcname-$pkgver.tar.gz")
+sha256sums=('e5bb3476190a5d42795c170c894c9dcb475587855bd535200cd7a2751e6e9869')
build() {
- cd "${srcdir}/${_srcname}-${pkgver}"
- make compile || return 1
+ cd "$_srcname-$pkgver"
+ make compile
}
package() {
- cd "${srcdir}/${_srcname}-${pkgver}"
- make prefix="${pkgdir}/usr/share" install || return 1
+ cd "$_srcname-$pkgver"
+ make prefix="$pkgdir/usr/share" install
- ## by default now we install also the contrib directory
- install -d -m755 $pkgdir/usr/share/emacs/site-lisp/org_contrib || return 1
- cp -r contrib/* $pkgdir/usr/share/emacs/site-lisp/org_contrib || return 1
+ ## by default now we install also the contrib directory
+ install -d -m755 $pkgdir/usr/share/emacs/site-lisp/org_contrib
+ cp -r contrib/* $pkgdir/usr/share/emacs/site-lisp/org_contrib
- ##! proper install of info files (thanks mdev)
- ##! replace "orgmode" with "org" in the following lines if you want
- ##! to replace emacs own org's info files. You also need to change the .install.
- install -D -m644 doc/org $pkgdir/usr/share/info/orgmode || return 1
- gzip -9 $pkgdir/usr/share/info/orgmode || return 1
- rm $pkgdir/usr/share/info/org || return 1
+ ##! proper install of info files (thanks mdev)
+ ##! replace "orgmode" with "org" in the following lines if you want
+ ##! to replace emacs own org's info files. You also need to change the .install.
+ install -D -m644 doc/org $pkgdir/usr/share/info/orgmode
+ gzip -9 $pkgdir/usr/share/info/orgmode
+ rm $pkgdir/usr/share/info/org
}
-