summaryrefslogtreecommitdiff
path: root/pcr/fwsnort/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-21 23:15:50 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-21 23:15:50 -0500
commit1a4554480341083f8a1240431c12ebe267843ecd (patch)
treead3a5139276c0ccae31b34d117538bd65d1ba703 /pcr/fwsnort/PKGBUILD
parent1953fb42ba73cad6e3d21b2529c8374a9b44362c (diff)
fwsnort-1.6.3-3: downgrade version
Diffstat (limited to 'pcr/fwsnort/PKGBUILD')
-rw-r--r--pcr/fwsnort/PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/pcr/fwsnort/PKGBUILD b/pcr/fwsnort/PKGBUILD
index a4b666dfa..1a0505faa 100644
--- a/pcr/fwsnort/PKGBUILD
+++ b/pcr/fwsnort/PKGBUILD
@@ -1,9 +1,8 @@
-# Contributor (Arch) : Colin Shea <colin@evaryont.me>
-# Maintainer (Parabola): Aurélien DESBRIÈRES <aurelien@hackers.camp>
-
+# Contributor (Arch): Colin Shea <colin@evaryont.me>
+# Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
pkgname=fwsnort
-pkgver=1.6.4
-pkgrel=1
+pkgver=1.6.3
+pkgrel=3
pkgdesc="application layer IDS/IPS by translating snort rules into iptables"
arch=('any')
url="http://www.cipherdyne.org/fwsnort/"
@@ -12,8 +11,9 @@ license=('GPL')
depends=('perl' 'perl-netaddr-ip' 'perl-iptables-parse' 'iptables' 'net-tools')
makedepends=('wget')
source=(http://www.cipherdyne.org/$pkgname/download/$pkgname-$pkgver.tar.bz2
- )
-
+ 'install_pl.patch')
+md5sums=('3e7501e4587a3e33615b604935c75e4e'
+ 'd7925e3f869ec8decb0e8336801350d6')
options=(emptydirs)
build() {
@@ -23,22 +23,22 @@ build() {
# - removes the root check
# - includes sbin as another place to check for binares
# - fixes various paths for utilities & the man page
- #patch -p1 -i $srcdir/install_pl.patch
+ patch -p1 -i $srcdir/install_pl.patch
# -S skips installing the perl modules, which we did with packages
# and --install-test-dir sets the INSTALL_ROOT to src/../test/fwsnort-test. An
# easy way to collect all the files into 1
- #./install.pl -S --install-test-dir
+ ./install.pl -S --install-test-dir
}
-#package() {
- #cp -r $srcdir/fwsnort-$pkgver/test/fwsnort-install/* -t $pkgdir
+package() {
+ cp -r $srcdir/fwsnort-$pkgver/test/fwsnort-install/* -t $pkgdir
# delete references to $pkgdir from fwsnort; they were made by the installer
# as part of installing to the test dir
- #cp -f $srcdir/fwsnort-$pkgver/fwsnort.conf $pkgdir/etc/fwsnort/fwsnort.conf
+ cp -f $srcdir/fwsnort-$pkgver/fwsnort.conf $pkgdir/etc/fwsnort/fwsnort.conf
# avoid a 'warning: directory permissions differ on etc/' line from pacman
- #chmod 755 $pkgdir/etc
-#}
+ chmod 755 $pkgdir/etc
+}
# vim:set ts=2 sw=2 et: