summaryrefslogtreecommitdiff
path: root/pcr/gentoo-functions
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-20 15:27:40 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-20 16:11:14 -0400
commit5211e23d484d82d06e1d32ee4b75ebe726e7b4cb (patch)
treef2ad27aa7191a9222d89b742d10907f275dbb722 /pcr/gentoo-functions
parentab860f2b06463ed4d68b7a4e3d71201d4176bc68 (diff)
pcr/netifrc: Update 0.6.{0→1}, fix up
- Update to 0.6.1 - groups=('base-openrc'), not 'openrc-base' - Add pcr/gentoo-functions as a separate package, rather than vendoring it - Depend on generic 'udev' stuff, rather than 'eudev' - install= is NOT WHERE DOCUMENTATION BELONGS - Use git tag signature verification pcr/gentoo-functions: - Is GPLv2, not 2-clause BSD - Don't inexplicably install to /usr/lib/parabola instead of /usr/lib/gentoo
Diffstat (limited to 'pcr/gentoo-functions')
-rw-r--r--pcr/gentoo-functions/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/gentoo-functions/PKGBUILD b/pcr/gentoo-functions/PKGBUILD
new file mode 100644
index 000000000..7ae9d92f0
--- /dev/null
+++ b/pcr/gentoo-functions/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer (Manjaro): artoo <artoo@manjaro.org>
+# Contributor (Manjaro): williamh <williamh@gentoo.org>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Luke Shumaker <lukeshu@parabola.nu>
+
+# Gentoo's ebuild file:
+# https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+pkgname=gentoo-functions
+pkgver=0.12
+pkgrel=1
+pkgdesc="Base functions for Gentoo systems"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/gentoo/$pkgname"
+license=('GPL2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gentoo/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('4a6ddb1d8be7b52aae68761fb26546663b6b0e74b155df263cddfbfa72373965')
+
+_makeargs=(
+ ROOTPREFIX=/usr
+ ROOTSBINDIR=/usr/bin
+)
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make "${_makeargs[@]}"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" "${_makeargs[@]}" install
+}