summaryrefslogtreecommitdiff
path: root/pcr/gforth/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@openmailbox.org>2017-10-31 21:01:05 -0300
committerDavid P <megver83@openmailbox.org>2017-10-31 21:01:05 -0300
commit8cb3de1669549474203564e712d3aa1e687b79f9 (patch)
tree421c499c7406705d8327752c81ecd7f6966ebad2 /pcr/gforth/PKGBUILD
parent7753a2f31e05b6ae2ed8c2fd47a93173944519ea (diff)
Fix pcr/gforth
What a crappy PKGBUILD it was
Diffstat (limited to 'pcr/gforth/PKGBUILD')
-rw-r--r--pcr/gforth/PKGBUILD62
1 files changed, 18 insertions, 44 deletions
diff --git a/pcr/gforth/PKGBUILD b/pcr/gforth/PKGBUILD
index 4625c721b..c7e1e0512 100644
--- a/pcr/gforth/PKGBUILD
+++ b/pcr/gforth/PKGBUILD
@@ -1,55 +1,29 @@
-# Maintainer: Luke R. <g4jc@openmailbox.org> GPG: rsa4096/3EAE8697
+# Maintainer: David P. <megver83@parabola.nu>
+# Maintainer: Luke R. <g4jc@openmailbox.org>
pkgname=gforth
pkgver=0.7.3
pkgrel=1
-pkgdesc="Gforth is a GNU implementation of the FORTH programing language. It uses GCC to compile a fast direct or indirect threaded Forth; Gforth is fully ANS FORTH compliant."
-arch=(i686 x86_64)
-url="https://www.gnu.org/software/gforth/"
+url="http://www.gnu.org/software/gforth/"
+pkgdesc="Fast and portable implementation of the ANS Forth language"
+arch=('i686' 'x86_64' 'armv7h')
license=('GPL3')
-makedepends=('gcc' 'autoconf' 'automake')
-depends=('libffi')
-optdepends=('texlive-core: make docs')
-source=("https://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz"
-"https://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz.sig"
-'PKGBUILD.sig'
-'PKGBUILD'
-"$pkgname.patch"
-"$pkgname.install")
-install=("$pkgname.install")
-validpgpkeys=('CB6E213A349B8DF9E96B622AC3F4FFCF3EAE8697' # PKGBUILD Maintainer's key
-'E50D62D449FD0E193706C2358B820BB767007C30') # Bernd Paysan's key
+depends=('libtool')
+source=("https://ftp.gnu.org/gnu/gforth/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
+options=('libtool')
+install=$pkgname.install
sha512sums=('f034234acfb0fc727f28b564432219a100b916c6df4b847794a55b2fc3b8ed8714eca6de0df67c7c427b7c2bb4dd00f65cfd34e6eb60181e41ab84fea30304e4'
-'33490f35551cecb5abf41b1fd2ae41eea13f57b64449cc39709f593cbd7a180df814fab5fb6c78718a17ffe918ae4ea82c50de884ac8429548d406940128834e'
-'SKIP'
-'SKIP'
-'81a5cbd3016e88b3eddc08b57d73ebc9b245767404f982c82df38a1c8de051852a9a560dc726aa6a945907a4a9dfe0d16eb4bedb010e1949331a5a95d8708b13'
-'c9537372978374e5f0b48e52bddcb08be0f57a7499277b7a0eca10c5e76e87a86fed0d0724e8fbfe3d88023d60a2109ffb697c519b23c411a3c0c7ba3f944335')
-
-pkgver() {
-tar -ztvf $pkgname-$pkgver.tar.gz | head -n1 | awk '{print $6}' | sed "s/gforth-//" | sed "s/\///" # get latest version number
-}
-
-prepare() {
-patch -p0 < $srcdir/$pkgname.patch
-## General cleanup patch for hardcoded and depreciated use of /usr/local in the source. We need to use /usr.
-}
+ 'SKIP')
+validpgpkeys=('E50D62D449FD0E193706C2358B820BB767007C30' # Bernd Paysan
+ )
build() {
- gpg --verify PKGBUILD.sig PKGBUILD
- echo "Note: If the GPG verification fails, import the PKGBUILD maintainer's GPG key. See: https://wiki.parabola.nu/GnuPG#Import_key"
- whirlpoolsum=('e16e1dfcccc1f02855da9f53407feaeca66fbe64586373aa4e8916c6b9f1dbbd023e4cd7908c8e943d0700c094dbd5e387f6c0b92492bf4e1ecc23692cc63932')
- [[ "$(openssl dgst -r -whirlpool $pkgname-$pkgver.tar.gz | awk '{print $1}')" = ${whirlpoolsum} ]] && echo "Whirlpool checksum passed." || { echo "Whirlpool checksum failed!!" ; exit 1; } # This is an added security layer. If SHA512 for some unlikely reason fails, whirlpool will check and abort if it too fails to match.
- cd $pkgname-$pkgver
- ./autogen.sh
- ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
- make
- ## make doc # if you install optional dependencies feel free to uncomment this. Requires TeXLive.
- make more
+ cd "$srcdir/$pkgname-$pkgver"
+ CFLAGS='-std=gnu99' ./configure --prefix=/usr
+ make PREFIX=/usr ${MAKEFLAGS}
}
package() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
- make DESTDIR="$pkgdir/" install
-} \ No newline at end of file
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}