summaryrefslogtreecommitdiff
path: root/pcr/gmusicbrowser/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-07-06 16:24:43 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-07-06 16:24:43 -0500
commit82c5017d49dc5fdd7ffa6489e79306561fa72199 (patch)
treeefe7d89a21cb430b14b9a68adfffeac522e9fec9 /pcr/gmusicbrowser/PKGBUILD
parent7069768d3a844582c5df59c80f7a6f75a28a14a0 (diff)
gmusicbrowser-1.1.14-3: updating version
Diffstat (limited to 'pcr/gmusicbrowser/PKGBUILD')
-rw-r--r--pcr/gmusicbrowser/PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/pcr/gmusicbrowser/PKGBUILD b/pcr/gmusicbrowser/PKGBUILD
index 7e0e5afc4..f8dd68ee2 100644
--- a/pcr/gmusicbrowser/PKGBUILD
+++ b/pcr/gmusicbrowser/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer (Arch): Spike29 <leguen.yannick@gmail.com>
# Contributor (Arch): jsteel <mail at jsteel dot org>
# Contributor (Arch): Corrado Primier <bardo@aur.archlinux.org>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=gmusicbrowser
-pkgver=1.1.10
+pkgver=1.1.14
pkgrel=3
-pkgdesc="A jukebox for large collections of mp3/ogg/flac files, written in perl"
+pkgdesc="A customizable open-source jukebox for large collections"
arch=('any')
url="http://gmusicbrowser.org"
license=('GPL3')
@@ -15,26 +16,35 @@ optdepends=('alsa-utils: enables the ALSA backend'
'mpg321: mp3 support for the ALSA backend'
'vorbis-tools: vorbis support for the ALSA backend'
'mplayer: enables the mplayer backend'
- 'perl-gstreamer: enables the gstreamer backend'
- 'gstreamer0.10-base: vorbis support for the gstreamer backend'
- 'gstreamer0.10-good-plugins: flac support for the gstreamer backend'
- 'gstreamer0.10-bad-plugins: mpc support for the gstreamer backend'
- 'gstreamer0.10-ugly-plugins: mp3 support for the gstreamer backend'
+ 'gstreamer: enables the gstreamer backend'
+ 'perl-glib-object-introspection: enables the gstreamer backend'
+ 'gst-plugins-base: vorbis support for the gstreamer backend'
+ 'gst-plugins-good: flac support for the gstreamer backend'
+ 'gst-plugins-bad: mpc support for the gstreamer backend'
+ 'gst-plugins-ugly: mp3 support for the gstreamer backend'
+ 'perl-gstreamer: enables the gstreamer0.10 backend'
+ 'gstreamer0.10-base: vorbis support for the gstreamer0.10 backend'
+ 'gstreamer0.10-good-plugins: flac support for the gstreamer0.10 backend'
+ 'gstreamer0.10-bad-plugins: mpc support for the gstreamer0.10 backend'
+ 'gstreamer0.10-ugly-plugins: mp3 support for the gstreamer0.10 backend'
+ 'perl-locale-gettext: localization support'
+ 'perl-gtk2-trayicon: tray icon support'
+ 'perl-gtk2-appindicator: app indicator plugin support'
'perl-gtk2-mozembed: web-based plugins support'
'perl-gtk2-webkit: alternative web-based plugin support'
- 'perl-html-parser: support for accented characters in lyrics plugin'
- 'perl-locale-gettext: localization support'
'perl-net-dbus: control gmusicbrowser through dbus and gnome hotkeys'
- 'perl-gtk2-notify: show notifications using libnotify' )
-conflicts=('gmusicbrowser-devel' 'gmusicbrowser-development' 'gmusicbrowser-git' 'gmusicbrowser-shimmer-git')
+ 'perl-gtk2-notify: show notifications using libnotify'
+ 'perl-html-parser: support for accented characters in lyrics plugin')
+conflicts=('gmusicbrowser-devel' 'gmusicbrowser-development' 'gmusicbrowser-git' 'gmusicbrowser-shimmer' 'gmusicbrowser-shimmer-git')
options=('!libtool')
install=$pkgname.install
-source=(https://github.com/shimmerproject/${pkgname}/archive/v${pkgver}.tar.gz)
+source=($url/download/$pkgname-$pkgver.tar.gz)
+md5sums=('8eb2d3f22e0734a7f5efbf4f0b2bd71e')
package() {
cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir/" DOCS="AUTHORS COPYING README NEWS INSTALL" install
+ make DESTDIR="$pkgdir/" install
# put some images in sane locations
install -Dm644 pix/trayicon.png "$pkgdir"/usr/share/icons/hicolor/16x16/apps/gmusicbrowser.png
@@ -42,4 +52,3 @@ package() {
install -Dm644 pix/gmusicbrowser.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/gmusicbrowser.png
install -Dm644 pix/gmusicbrowser.png "$pkgdir"/usr/share/pixmaps/gmusicbrowser.png
}
-md5sums=('25cbef3bd7c6666a036dcc337adcb387')