summaryrefslogtreecommitdiff
path: root/pcr/gnome-shell-pomodoro/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-11-30 15:55:18 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-11-30 15:55:18 -0300
commit8d014fb2193f1dd58e92ceee01192b5bfc92d41b (patch)
treec145f046da2d0b7d8875bfdcd0413d6dd9b34598 /pcr/gnome-shell-pomodoro/PKGBUILD
parentb81b9c5b40a81734c6cd43ae6396e91965ca84a6 (diff)
gnome-shell-pomodoro: add new package to [pcr] -> https://labs.parabola.nu/issues/863
Diffstat (limited to 'pcr/gnome-shell-pomodoro/PKGBUILD')
-rw-r--r--pcr/gnome-shell-pomodoro/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/pcr/gnome-shell-pomodoro/PKGBUILD b/pcr/gnome-shell-pomodoro/PKGBUILD
new file mode 100644
index 000000000..3db26a390
--- /dev/null
+++ b/pcr/gnome-shell-pomodoro/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer (Arch): Andrejs Mivreņiks <gim at fastmail dot fm>
+# Contributor (Arch): Janne Haapsaari <haaja@iki.fi>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+pkgname=gnome-shell-pomodoro
+pkgver=0.11.1
+pkgrel=1.parabola1
+pkgdesc='A time management utility for GNOME based on the pomodoro technique, without nonfree Skype support'
+arch=('i686' 'x86_64')
+url='https://github.com/codito/gnome-shell-pomodoro/'
+license=('GPL3')
+depends=('gnome-desktop' 'libcanberra' 'upower' 'gstreamer' 'gobject-introspection' 'perl-xml-sax-expat' 'telepathy-glib')
+makedepends=('intltool' 'vala' 'gnome-common' 'docbook2x')
+conflicts=('gnome-shell-pomodoro-git')
+install='gschemas.install'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/codito/gnome-pomodoro/archive/$pkgver.tar.gz"
+ 'libre.patch')
+sha256sums=('90217c2df07ef7da2f1e8fba4e657a18954d03bc09fe93ba4405aa6e12df1a7a'
+ 'acb05ba020439a6ae20a87b9f40b51a2b0aff836180349e7750e647e479148dc')
+
+prepare() {
+ cd "$srcdir/gnome-pomodoro-$pkgver"
+ # Remove Skype stuff
+ rm -rv lib/skype{,-plugin}.vala
+ patch -Np1 -i ../libre.patch
+
+ # Fixes some build issues when 'docbook2x' package is installed
+ # Big thanks to user maus25 for the fix
+ sed -i "s/docbook2man \$?/docbook2man --sgml \$?/g" man/Makefile.am
+
+ ./autogen.sh --prefix=/usr --datadir=/usr/share
+}
+
+build() {
+ cd "$srcdir/gnome-pomodoro-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/gnome-pomodoro-$pkgver"
+ make DESTDIR="$pkgdir" install
+}