summaryrefslogtreecommitdiff
path: root/pcr/guix
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-08-31 17:37:15 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-08-31 17:37:15 -0300
commit6c8b4875bc0332d146f9bdaad6d07f210675a7d8 (patch)
treefd6d3a8e078953ed2d4e4b4a51578f356145e1cc /pcr/guix
parent1a18bfac36a2c5c7b6a55b0b5df47288f5ec81ea (diff)
guix-0.11.0-2: updating version
Diffstat (limited to 'pcr/guix')
-rw-r--r--pcr/guix/PKGBUILD28
-rw-r--r--pcr/guix/guix.install14
2 files changed, 22 insertions, 20 deletions
diff --git a/pcr/guix/PKGBUILD b/pcr/guix/PKGBUILD
index 1be76b0d6..477c1829e 100644
--- a/pcr/guix/PKGBUILD
+++ b/pcr/guix/PKGBUILD
@@ -3,15 +3,16 @@
# In order to verify the PGP signature of the source archive, you may need to
# use this command to download the needed public key:
-# gpg --recv-keys 090B11993D9AEBB5
+# gpg --recv-keys 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
pkgname=guix
-pkgver=0.10.0
-pkgrel=1
+pkgver=0.11.0
+pkgrel=2
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
+options=('!strip')
makedepends=(
'bash-completion'
'emacs' # Please remove this if you are not going to use guix in emacs
@@ -23,7 +24,8 @@ depends=(
'sqlite>=3.6.19'
'bzip2'
'gnutls'
- 'libgcrypt')
+ 'libgcrypt'
+ 'zlib')
optdepends=(
'bash-completion: to enable bash programmable completion'
'emacs: to enable Emacs Interface'
@@ -32,8 +34,8 @@ optdepends=(
source=(
"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
-sha1sums=('36be27ea1f1314d508bd80c84cadf7eafe974093'
- '915ffda358412018a413ae07054ed19f725e3797')
+sha1sums=('bd12d65a46c8eef3b490efea6ac953b995d524eb'
+ 'a9080412df96832d22e57a1bcc76e3016f93f0b0')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
build() {
@@ -63,4 +65,18 @@ package() {
make DESTDIR="${pkgdir}" install
# Remove the unused upstart service file
rm -r ${pkgdir}/usr/lib/upstart
+ # The default makepkg strip option cannot be used here because binaries
+ # installed in /usr/share must not be stripped.
+ # To keep user-defined 'strip' and 'debug' options useful, we still
+ # depend on 'tidy_strip' function provided by makepkg to do the stripping
+ # work. To make the function useful, we have to temporarily remove the
+ # '!strip' option from 'options' array. However, assignments to 'options'
+ # cause mksrcinfo to insert wrong lines to .SRCINFO, so they have to be
+ # put in eval.
+ eval 'options=()'
+ cd ${pkgdir}/usr/bin
+ tidy_strip
+ cd ${pkgdir}/usr/lib
+ tidy_strip
+ eval 'options=("!strip")'
}
diff --git a/pcr/guix/guix.install b/pcr/guix/guix.install
index 54f7659b6..c2baacd9f 100644
--- a/pcr/guix/guix.install
+++ b/pcr/guix/guix.install
@@ -1,6 +1,3 @@
-infodir=usr/share/info
-file=guix.info
-
post_install() {
echo "Guix 0.8.3 already provides a systemd service file in its release,"
echo "so the one included in AUR package is now removed. Please use the"
@@ -14,17 +11,6 @@ post_install() {
echo
echo "If you have /etc/systemd/system/guix.service.d, please also remember"
echo "to review its content and rename it to guix-daemon.service.d."
- [[ -x usr/bin/install-info ]] || return 0
- install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-pre_remove() {
- [[ -x usr/bin/install-info ]] || return 0
- install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
}
# vim:set ts=2 sw=2 ft=sh et: