summaryrefslogtreecommitdiff
path: root/pcr/guix
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-04-24 02:52:19 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-04-24 02:52:19 -0300
commit8de359ab39279ab62f2363a5c4ff33b77e80338d (patch)
tree04be389039577db8ffe16b55aa9f50e6d112b634 /pcr/guix
parent4351d6db7119912456a9d07c97a9af90f6d247b3 (diff)
guix-0.10.0-1: updating version
Diffstat (limited to 'pcr/guix')
-rw-r--r--pcr/guix/PKGBUILD43
1 files changed, 27 insertions, 16 deletions
diff --git a/pcr/guix/PKGBUILD b/pcr/guix/PKGBUILD
index fa2f9bbd3..1be76b0d6 100644
--- a/pcr/guix/PKGBUILD
+++ b/pcr/guix/PKGBUILD
@@ -1,55 +1,66 @@
# Maintainer (Arch): lantw44 (at) gmail (dot) com
-# Modified from guix-git 20130119 PKGBUILD
+# Modified from guix-git 20130119 PKGBUILD
# In order to verify the PGP signature of the source archive, you may need to
# use this command to download the needed public key:
# gpg --recv-keys 090B11993D9AEBB5
pkgname=guix
-pkgver=0.9.0
-pkgrel=2
-pkgdesc="GNU guix is a purely functional package manager"
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
makedepends=(
'bash-completion'
- 'emacs' # Please remove this if you are not going to use guix in emacs
- 'guile-json')
+ 'emacs' # Please remove this if you are not going to use guix in emacs
+ 'graphviz' # Please remove this if you are not going to use guix in emacs
+ 'guile-json'
+ 'help2man')
depends=(
'guile>=2.0.7'
'sqlite>=3.6.19'
'bzip2'
+ 'gnutls'
'libgcrypt')
optdepends=(
'bash-completion: to enable bash programmable completion'
'emacs: to enable Emacs Interface'
+ 'graphviz: to enable Emacs Interface'
'guile-json: to import packages from cpan, gem, pypi')
source=(
"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
-sha1sums=('765de53aa344a801c3d376cf1e050650cec58039'
- 'ab25cfdb39ff6d53458c07a8ab9b397a7bc8c9c5')
+sha1sums=('36be27ea1f1314d508bd80c84cadf7eafe974093'
+ '915ffda358412018a413ae07054ed19f725e3797')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
build() {
bash_completion_dir="`pkg-config --variable=completionsdir bash-completion`"
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --sbindir=/usr/bin --localstatedir=/var \
+ ./configure --prefix=/usr --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/${pkgname} --localstatedir=/var \
--sysconfdir=/etc --with-bash-completion-dir="${bash_completion_dir}" \
--disable-rpath
make
}
-#check() {
-# cd ${srcdir}/${pkgname}-${pkgver}
-# # Don't run container tests if the kernel doesn't support user namespace
-# zgrep "CONFIG_USER_NS=y" /proc/config.gz || \
-# sed -i 's|tests/guix-environment-container.sh||' Makefile
-# make check
-#}
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # Don't run tests requiring user namespace
+ if unshare -Ur true; then :; else
+ sed -i 's|tests/syscalls.scm||' Makefile
+ sed -i 's|tests/containers.scm||' Makefile
+ sed -i 's|tests/guix-environment-container.sh||' Makefile
+ fi
+ # Make sure we have a valid shell accepting -c option
+ SHELL=/bin/sh make check
+}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+ # Remove the unused upstart service file
+ rm -r ${pkgdir}/usr/lib/upstart
}