summaryrefslogtreecommitdiff
path: root/pcr/jitsi/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-22 09:28:03 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-22 09:28:03 +0100
commit4f2994c27a16f2586c6e119e5507c1335fe8bec3 (patch)
tree80821a9921d37d18c22f8252adae6e7d2441a8c1 /pcr/jitsi/PKGBUILD
parent333230cb19e4db08672276a2ce661fd8a75845fc (diff)
pcr/jitsi: updated to 2.10.5550
Diffstat (limited to 'pcr/jitsi/PKGBUILD')
-rw-r--r--pcr/jitsi/PKGBUILD73
1 files changed, 17 insertions, 56 deletions
diff --git a/pcr/jitsi/PKGBUILD b/pcr/jitsi/PKGBUILD
index 715ece24e..92b93e871 100644
--- a/pcr/jitsi/PKGBUILD
+++ b/pcr/jitsi/PKGBUILD
@@ -1,72 +1,33 @@
-# Contributor (Arch): Xavier Devlamynck <magicrhesus@ouranos.be>
-# Contributor (Arch): Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Maintainer (AUR): Xavier Devlamynck <magicrhesus@ouranos.be>
+# Contributors (AUR): Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# parabola changes and rationale:
+# - corrected used license
+
pkgname=jitsi
-pkgver=2.8.5426
-pkgrel=1
+pkgver=2.10.5550
+pkgrel=4
pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator)"
arch=('i686' 'x86_64')
url="http://jitsi.org"
-license=('LGPL')
+license=('Apache')
depends=('java-runtime')
-makedepends=('apache-ant' 'java-environment')
+makedepends=('apache-ant' 'java-environment-common')
options=(!strip !emptydirs zipman !libtool docs)
-source=("http://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
+source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
jitsi.desktop
- jitsi.sh
- drop-open-term-on-index-jn-html.patch)
-sha256sums=('e649867e186cf195c4b1bb159d7ffe0a38c4dc60659e5c55f9a74461a309f36c'
+ jitsi.sh)
+sha256sums=('cdfc6f038d1b877c42d26dba1864ac7c6b554dd55c18767a29f2db3618647287'
'61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
- '529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5'
- 'a862465431e9d272e00bb9aafe56edec0d5c4f3718062add53972685adb90631')
-
-prepare() {
- cd $srcdir/$pkgname
+ 'c47bfa98fe36378f2e7b947cd248582f5a90c1b169d53d158badb00439fdc6c7')
+build()
+{
+ cd "${srcdir}/${pkgname}"
# append the build revision to the jitsi version
sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
-
- # remove Open Source term
- patch -Np0 -i ../drop-open-term-on-index-jn-html.patch
- sed -i 's|Open Source / ||;
- s|open source / ||;
- s|Open Source|Free Software|;
- s|open source|free software|;
- ' $(grep -ril 'open source')
- sed -i 's|OpenSource / ||;
- s|opensource / ||;
- s|OpenSource|FreeSoftware|;
- s|opensource|freesoftware|;
- ' $(grep -ril opensource)
-
- # remove Linux term
- sed -i '/, Linux/ s|Linux|GNU/Linux|;
- /And Linux/ s|Linux|GNU/Linux|;
- /and Linux/ s|Linux|GNU/Linux|;
- /For Linux/ s|Linux|GNU/Linux|;
- /for Linux/ s|Linux|GNU/Linux|;
- /Linux,/ s|Linux|GNU/Linux|;
- /Linux and/ s|Linux|GNU/Linux|;
- /Linux distribution/ s|Linux|GNU/Linux|;
- /Linux machine/ s|Linux|GNU/Linux|;
- /Linux operating/ s|Linux|GNU/Linux|;
- /Linux OS/ s|Linux|GNU/Linux|;
- /Linux specific/ s|Linux|GNU/Linux|;
- /Linux system/ s|Linux|GNU/Linux|;
- /Under Linux/ s|Linux|GNU/Linux|;
- /under Linux/ s|Linux|GNU/Linux|;
- /On Linux/ s|Linux|GNU/Linux|;
- /on Linux/ s|Linux|GNU/Linux|;
- s|GNU/GNU|GNU|;
- s|GNU/Linux kernel|Linux kernel|;
- s|GNU/Linux specific kernel|Linux specific kernel|;
- ' $(grep -rl Linux)
-}
-
-build() {
- cd $srcdir/$pkgname
. /etc/profile.d/apache-ant.sh
ant rebuild
}