summaryrefslogtreecommitdiff
path: root/pcr/liblas/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-04-30 13:02:59 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-04-30 13:02:59 -0500
commitb9c634c914000edcc3faba77b668a883582c386c (patch)
tree410bba62576e30efcd48db8f9ad33bcbc826197f /pcr/liblas/PKGBUILD
parent47b288802ecfcb9374f0fda8c01a87fc9ae733eb (diff)
liblas-1.8.0-2: add new package to [pcr]
Diffstat (limited to 'pcr/liblas/PKGBUILD')
-rw-r--r--pcr/liblas/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/pcr/liblas/PKGBUILD b/pcr/liblas/PKGBUILD
new file mode 100644
index 000000000..ede823f09
--- /dev/null
+++ b/pcr/liblas/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor (Arch) : Patryk Kowalczyk <patryk AT kowalczyk DOT WS>
+# Contributor (Arch) : Maciej Sieczka <msieczka at sieczka dot org>
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=liblas
+pkgver=1.8.0
+pkgrel=2
+pkgdesc="library for embedding read and write support of the ASPRS LAS format into your own C/C++ applications, and a suite of command-line utilities based on LASTools for inspecting, manipulating, transforming, and processing LAS LiDAR data"
+arch=(i686 x86_64)
+url="http://www.liblas.org/"
+license=('BSD3')
+groups=()
+depends=('boost-libs>=1.38.0' 'gdal>=1.7.0' 'libgeotiff>=1.2.5' 'laszip>=2.0.1' 'libtiff')
+makedepends=('boost>=1.38.0' 'cmake')
+optdepends=('oci: Oracle Instant Client, see http://www.liblas.org/compilation.html (must recompile)')
+provides=(liblas)
+conflicts=(liblas-hg)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/libLAS/libLAS/archive/${pkgver}.tar.gz)
+#http://download.osgeo.org/liblas/libLAS-${pkgver}.tar.gz)
+noextract=()
+
+build() {
+ cd "$srcdir/libLAS-$pkgver"
+
+ msg 'Configuring build...'
+ cmake -DWITH_GEOTIFF=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_GEOTIFF=ON -DWITH_GDAL=ON -DWITH_LASZIP=ON -G "Unix Makefiles" .
+
+ msg 'Building...'
+ make
+}
+
+package() {
+ cd "$srcdir/libLAS-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums=('e7f86bf90166a3ee3de2bc57bb809972')