summaryrefslogtreecommitdiff
path: root/pcr/luabind/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-01-02 10:58:51 -0200
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-01-02 10:58:51 -0200
commit593a1335dd0bb92ac9f1e2a7a2ca12b3b3f06cd5 (patch)
tree843318780ef5144fbb0dee3ab9fa3803a93e74af /pcr/luabind/PKGBUILD
parentbc8cb28521bc78536ba1cdec53c798fbc478a75a (diff)
luabind: add pkg to repo pcr
Diffstat (limited to 'pcr/luabind/PKGBUILD')
-rw-r--r--pcr/luabind/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/pcr/luabind/PKGBUILD b/pcr/luabind/PKGBUILD
new file mode 100644
index 000000000..da47f927b
--- /dev/null
+++ b/pcr/luabind/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 78820 2012-10-25 06:47:28Z foutrelis $
+# Maintainer: Jakob Gruber <jakob.gruber@gmail.com>
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: rayte <rabyte.at.gmail.dot.com>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+
+pkgname=luabind
+pkgver=0.9.1
+pkgrel=3
+pkgdesc='A library that helps you create bindings between C++ and Lua'
+arch=(
+ i686
+ x86_64
+ mips64el
+)
+url="http://www.rasterbar.com/products/$pkgname.html"
+license=MIT
+makedepends=(
+ boost
+ boost-build
+ unzip
+)
+depends=(
+ gcc-libs
+ lua51
+)
+source=(
+ "http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ ${pkgname}_boost.patch
+)
+md5sums=(
+ 8a323fb51d07dad5cfdb12c432793d55
+ d62ae6fc635300bc659df9dbb587ac53
+)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -Np1 -i $srcdir/${pkgname}_boost.patch
+
+ # build luabind
+ setarch $CARCH bjam release --prefix=$pkgdir/usr link=static,shared
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ setarch $CARCH bjam release --prefix=$pkgdir/usr link=static,shared install
+
+ # copy license
+ install -Dm644 $srcdir/$pkgname-$pkgver/LICENSE \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}