summaryrefslogtreecommitdiff
path: root/pcr/maliit-plugins/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-07-06 22:04:31 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-07-06 22:04:31 -0600
commit2967b22c6179ded9cc01496e10dcb0f292d0c182 (patch)
tree9219e7dc564f3dc8af29ea142c4b5d409ea74310 /pcr/maliit-plugins/PKGBUILD
parent55677d14e4829d6a7859333d3560db346c228fdf (diff)
parente84010fb9a6f81d96d9c54661a7abde97a0eb187 (diff)
Merge branch 'master-remote' into master-undelete
Diffstat (limited to 'pcr/maliit-plugins/PKGBUILD')
-rw-r--r--pcr/maliit-plugins/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcr/maliit-plugins/PKGBUILD b/pcr/maliit-plugins/PKGBUILD
new file mode 100644
index 000000000..cdab07003
--- /dev/null
+++ b/pcr/maliit-plugins/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jon Nordby <jononor@gmail.com>
+# Maintainer: Jon Nordby <jononor@gmail.com>
+
+pkgname=maliit-plugins
+pkgver=0.99.0
+pkgrel=1
+pkgdesc="Maliit Input Methods - Plugins"
+arch=('x86_64' 'i686')
+url="http://maliit.org"
+license=('LGPL')
+depends=('qt5-base' 'maliit-framework')
+source=(http://maliit.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+ config.patch)
+md5sums=('29f07d937803a61e74301e4616d55dbb'
+ 'f43d45c9917924750edf36000492bd73')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ # fix issue on building
+ patch -Np1 -i "$srcdir/config.patch"
+
+ # BUILD
+ qmake -r . CONFIG+=notests
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ make install INSTALL_ROOT="$pkgdir/"
+}