summaryrefslogtreecommitdiff
path: root/pcr/netifrc/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2016-07-18 15:22:37 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2016-07-18 15:22:37 -0500
commit3e21837e556f88508a4606808366abd6a5556c4f (patch)
treee0f46ef50042fa28638980b17e094d4a3d9beb86 /pcr/netifrc/PKGBUILD
parent6d5806f93b77647d78dd582326d57c87b58e2ce6 (diff)
netifrc-0.4.0-1: updating version
Diffstat (limited to 'pcr/netifrc/PKGBUILD')
-rw-r--r--pcr/netifrc/PKGBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/pcr/netifrc/PKGBUILD b/pcr/netifrc/PKGBUILD
index 9bab41ae8..b9f1f34f5 100644
--- a/pcr/netifrc/PKGBUILD
+++ b/pcr/netifrc/PKGBUILD
@@ -2,18 +2,19 @@
# Contributor (Manjaro): williamh <williamh@gentoo.org>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_src_uri="https://github.com"
+_url="https://github.com"
-_net_uri="${_src_uri}/gentoo/netifrc/archive"
-_func_uri="${_src_uri}/gentoo/gentoo-functions/archive"
+#_net_url="${_url}/gentoo/netifrc/archive"
+_net_url='http://dev.gentoo.org/~robbat2/distfiles'
+_func_url="${_url}/gentoo/gentoo-functions/archive"
_func_ver=0.10
pkgname=netifrc
-pkgver=0.3.1
-pkgrel=7
+pkgver=0.4.0
+pkgrel=1
pkgdesc="Gentoo Network Interface Management Scripts"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('i686' 'x86_64')
url="http://www.gentoo.org/proj/en/base/openrc/"
license=('BSD2')
groups=('openrc-base')
@@ -21,14 +22,19 @@ depends=('udev-openrc')
conflicts=('systemd-sysvcompat')
install=${pkgname}.install
backup=('etc/conf.d/net')
-source=("${pkgname}-${pkgver}.tar.gz::${_net_uri}/${pkgver}.tar.gz"
- "gentoo-functions-${_func_ver}.tar.gz::${_func_uri}/${_func_ver}.tar.gz"
- 'LICENSE')
-sha256sums=('8ae41223cdc735eee8303e93959b31b6aeae6f1a08661ef5baa6373dd86419c7'
- '709c8b22f404001a512e47a7a4d3192070b3e150fb9d0f943de09736d665b0db'
- '28875cc6cb52e93657b96cf1bf0cc3b91891cdcbbc3196007c8cd93c6e22078f')
+# source=("${pkgname}-${pkgver}.tar.gz::${_net_url}/${pkgver}.tar.gz"
+# "gentoo-functions-${_func_ver}.tar.gz::${_func_url}/${_func_ver}.tar.gz")
+source=("${_net_url}/${pkgname}-${pkgver}.tar.bz2"
+ "gentoo-functions-${_func_ver}.tar.gz::${_func_url}/${_func_ver}.tar.gz")
+sha256sums=('cc5c10d567530f64ca8c4fb8dcfc8218d102144f83393e1db769a5a5374c00df'
+ '709c8b22f404001a512e47a7a4d3192070b3e150fb9d0f943de09736d665b0db')
-_id="parabola"
+if [ -f /etc/os-release ]; then
+ . /etc/os-release
+ _id=$ID
+else
+ _id=manjaro
+fi
_net_args=(SYSCONFDIR=/etc)
_net_args+=(PREFIX=/usr)
_net_args+=(SBINDIR=/usr/bin)
@@ -51,16 +57,14 @@ package() {
make DESTDIR="${pkgdir}" "${_net_args[@]}" install
install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/doc/net.example" "${pkgdir}/etc/conf.d/net"
- install -d "${pkgdir}/etc/runlevels//boot"
- sed -e 's|#!/usr/bin/runscript|#!/usr/bin/openrc-run|' \
- -i "${pkgdir}/etc/init.d/net.lo"
+ install -d "${pkgdir}/etc/runlevels/boot"
ln -sf "/etc/init.d/net.lo" "${pkgdir}/etc/runlevels/boot/net.lo"
cd ${srcdir}/gentoo-functions-${_func_ver}
make DESTDIR="${pkgdir}" "${_func_args[@]}" install
sed -e "s|/lib/gentoo/functions.sh|/usr/lib/$_id/functions.sh|g" \
- -i "${pkgdir}/usr/lib/${pkgname}/sh/functions.sh"
+ -i "${pkgdir}/usr/lib/${pkgname}/sh/functions.sh"
- install -Dm644 ${srcdir}/LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}