summaryrefslogtreecommitdiff
path: root/pcr/newlisp/PKGBUILD
diff options
context:
space:
mode:
authoraurelien <tek@localhost.localdomain>2012-12-30 18:57:37 +0100
committeraurelien <tek@localhost.localdomain>2012-12-30 18:57:37 +0100
commitb6cb10de275cea63bab0bee2a98342afa4fdc4ee (patch)
tree9736770dbd6bf695a100eb88a00de98b70a9f262 /pcr/newlisp/PKGBUILD
parentd731a980f156ec8d47292e47b63a17bced3d0268 (diff)
+ chm2pdf newlisp emacs-newlisp
Diffstat (limited to 'pcr/newlisp/PKGBUILD')
-rw-r--r--pcr/newlisp/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/pcr/newlisp/PKGBUILD b/pcr/newlisp/PKGBUILD
new file mode 100644
index 000000000..a53106390
--- /dev/null
+++ b/pcr/newlisp/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: scrawler <scrawler@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurélien DESBRIÈRES <aurelien@cwb.IO>
+
+pkgname=newlisp
+pkgver=10.4.5
+pkgrel=1
+pkgdesc="newLISP is a LISP like, general purpose scripting language."
+url="http://www.newlisp.org"
+license=('GPL')
+arch=('x86_64' 'i686')
+depends=('readline')
+optdepends=('openjdk6')
+options=('docs')
+source=(http://newlisp.org/downloads/$pkgname-$pkgver.tgz)
+install=$pkgname.install
+
+build() {
+cd $srcdir/$pkgname-$pkgver
+./configure
+[ $CARCH = "x86_64" ] && make -f makefile_linuxLP64_utf8
+[ $CARCH = "i686" ] && make -f makefile_linux_utf8
+install -d $pkgdir/usr/bin
+install -d $pkgdir/usr/share/man/man1
+make bindir=$pkgdir/usr/bin mandir=$pkgdir/usr/share/man \
+datadir=$pkgdir/usr/share install
+}