summaryrefslogtreecommitdiff
path: root/pcr/openfoam3.0-git/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-23 14:28:24 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-23 14:28:24 +0100
commit417e30597622622f8cec3beac34745a290412615 (patch)
treeeaccaa5d13da03c738221c53f1e5922c620f614b /pcr/openfoam3.0-git/PKGBUILD
parent87879c344dc0d60c2cc804a491e95c73d8a34948 (diff)
pcr/openfoam3.0-git: updated to 20170710.221b8ab7
Diffstat (limited to 'pcr/openfoam3.0-git/PKGBUILD')
-rw-r--r--pcr/openfoam3.0-git/PKGBUILD71
1 files changed, 62 insertions, 9 deletions
diff --git a/pcr/openfoam3.0-git/PKGBUILD b/pcr/openfoam3.0-git/PKGBUILD
index 69b7fc5d6..17503a202 100644
--- a/pcr/openfoam3.0-git/PKGBUILD
+++ b/pcr/openfoam3.0-git/PKGBUILD
@@ -1,5 +1,10 @@
-# Original Contributor (Arch): aquavitae <aquavitae69: gmail>
-# Current Maintainer (Arch): Andrew Fischer <andrew_at_ltengsoft.com>
+# Original Contributor (AUR): aquavitae <aquavitae69: gmail>
+# Current Maintainer (AUR): Andrew Fischer <andrew_at_ltengsoft.com>
+# Packager (AUR): Heavysink
+
+# parabola changes and rationale:
+# - removed "open source" term from pkgdesc
+# - removed parametis support
pkgname=openfoam3.0-git
@@ -7,23 +12,37 @@ pkgname=openfoam3.0-git
_distpkgname=OpenFOAM
_distpkgver=3.0.x
_gitname=$_distpkgname-$_distpkgver
-pkgver=20160803.4b5e129
-pkgrel=1.parabola1
+pkgver=20170710.221b8ab7
+pkgrel=4
pkgdesc="The libre CFD toolbox, without nonfree parmetis support"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url="http://www.openfoam.com"
license=('GPL')
groups=()
depends=('cgal' 'paraview' 'scotch' 'boost')
-makedepends=('git')
+makedepends=('git' 'flex')
optdepends=()
replaces=()
backup=()
options=()
-source=(git+https://github.com/OpenFOAM/OpenFOAM-3.0.x.git)
+source=(git+https://github.com/OpenFOAM/OpenFOAM-3.0.x.git
+ 'decomp-options.patch'
+ 'paraFoam.patch'
+ 'scotch-options.patch'
+ 'boost.patch'
+ 'prefs.sh'
+ 'scotch.sh'
+ 'paraview.sh')
noextract=()
install=openfoam.install
-md5sums=('SKIP')
+md5sums=('SKIP'
+ 'dcb09c65c450601203f48f7d5177ced2'
+ 'fb84ecc41b63304064b88ee3291513be'
+ '905fbd21aa780a57530d65818425ec6c'
+ 'e0bc9bb43c48acbe06fc834cb93ce949'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -32,11 +51,44 @@ pkgver() {
build() {
+ # Extract the current version and major of paraview and of scotch for use in the system preferences
+ _pversion1=`pacman -Q {paraview,paraview-manta,paraview-git} | sed -e 's/.* //; s/-.*//g'`
+ _pversion=`echo $_pversion1 | grep .`
+ _pmajor=`echo $_pversion | cut -d '.' -f1`
+ _sversion=`pacman -Q scotch | sed -e 's/.* //; s/-.*//g'`
+
+ # Generate and install the system preferences file
+ echo "compilerInstall=system" > $startdir/prefs.sh
+ echo "export WM_MPLIB=SYSTEMOPENMPI" >> $startdir/prefs.sh
+ echo "export ParaView_VERSION=$_pversion" >> $startdir/prefs.sh
+ echo "export ParaView_MAJOR=$_pmajor" >> $startdir/prefs.sh
+ cp $startdir/prefs.sh $srcdir/$_gitname/etc || return 1
+
+ # Generate the scotch.sh file for parabola
+ echo "export SCOTCH_VERSION=scotch_$_sversion" > $startdir/scotch.sh
+ echo "export SCOTCH_ARCH_PATH=/usr" >> $startdir/scotch.sh
+ cp $startdir/scotch.sh $srcdir/$_gitname/etc/config || return 1
+
+ # Generate the paraview.sh file for Paraview plugin
+ sed -i -e "s|paraviewversion|ParaView_VERSION=${_pversion}|g" ${srcdir}/paraview.sh
+ sed -i -e "s|paraviewmajor|ParaView_MAJOR=${_pmajor}|g" ${srcdir}/paraview.sh
+ cp ${srcdir}/paraview.sh ${srcdir}/${_distpkgname}-3.0.x/etc/config #|| return 1
+
+ # Patch for openmpi paths, and ptscotch link lines
+ patch -p1 < $startdir/decomp-options.patch
+ patch -p1 < $startdir/paraFoam.patch
+ patch -p1 < $startdir/scotch-options.patch
+ patch -p1 < $startdir/boost.patch
+
# Setup the build environment
export FOAM_INST_DIR=$srcdir
foamDotFile=$srcdir/$_gitname/etc/bashrc
[ -f $foamDotFile ] && . $foamDotFile || return 1
+ #Fix flex version
+ cd ${srcdir}/$_gitname
+ find . -name '*.L' -print -exec sed -i -e 's|YY_FLEX_SUBMINOR_VERSION < 34|YY_FLEX_SUBMINOR_VERSION < 34 \&\& YY_FLEX_MINOR_VERSION < 6|g' {} \;
+
# Enter build directory
cd "$srcdir/$_gitname" || return 1
@@ -44,9 +96,10 @@ build() {
./Allwmake || return 1
wclean all || return 1
wmakeLnIncludeAll || return 1
+
}
package() {
- cd "$srcdir"
+ cd "$startdir"
# Create destination directories
install -d "$pkgdir/opt/$_distpkgname" "$pkgdir/etc/profile.d" || return 1