summaryrefslogtreecommitdiff
path: root/pcr/papis/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-03-05 13:29:08 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-03-05 13:29:34 +0100
commitf33401dbca698b90b3e567f8fbb7a6a1a12b6173 (patch)
tree12eeba48b0dea4e6cead2b72006a96fb7cb3d2ed /pcr/papis/PKGBUILD
parent7ecfe3c9184e9abc3a2d9118190af415f95f8b50 (diff)
pcr/papis: added, plus dependencies
Diffstat (limited to 'pcr/papis/PKGBUILD')
-rw-r--r--pcr/papis/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr/papis/PKGBUILD b/pcr/papis/PKGBUILD
new file mode 100644
index 000000000..1503d0271
--- /dev/null
+++ b/pcr/papis/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname="papis"
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Powerful and highly extensible command-line based document and bibliography manager."
+arch=(any)
+url="https://github.com/papis/papis"
+license=('GPLv3')
+depends=("python-setuptools"
+ "python-papis_python_rofi"
+ "python-requests"
+ "python-argcomplete"
+ "python-pyparsing"
+ "arxiv2bib"
+ "python-yaml"
+ "python-chardet"
+ "python-beautifulsoup4"
+ "python-vobject"
+ "python-prompt_toolkit"
+ "python-bibtexparser"
+ "python-unidecode"
+ "python-pyparser"
+ "python-pypi-magic"
+ "python-pylibgen"
+ "python-urwid"
+ "python-habanero")
+source=($pkgname-$pkgver.tar.gz::https://github.com/papis/papis/archive/v$pkgver.tar.gz)
+sha256sums=('7463ac387b50b77ca122b2febdb21f8f7c689395f13242542ba510957dc358b7')
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i "s/.*configparser/#&/" setup.py
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --prefix="/usr"
+}