summaryrefslogtreecommitdiff
path: root/pcr/penguin-command/PKGBUILD
diff options
context:
space:
mode:
authorGaming4JC <g4jc@openmailbox.org>2016-10-09 15:26:43 -0400
committerGaming4JC <g4jc@openmailbox.org>2016-10-09 15:26:43 -0400
commita1422018f86ad45b2b07ccc016e0e32f5bcca8c9 (patch)
tree13719bf044bc719f85c51aea5bc30e33dd77c1f6 /pcr/penguin-command/PKGBUILD
parent0c571ee8bf405a85e1a072348121224e52452ac2 (diff)
add desktop icon to penguin-command
Diffstat (limited to 'pcr/penguin-command/PKGBUILD')
-rw-r--r--pcr/penguin-command/PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/pcr/penguin-command/PKGBUILD b/pcr/penguin-command/PKGBUILD
index c6074a577..57e146e82 100644
--- a/pcr/penguin-command/PKGBUILD
+++ b/pcr/penguin-command/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=penguin-command
pkgver=1.6.11
-pkgrel=2
+pkgrel=3
pkgdesc="Clone of the classic Missile Command game with better graphics and music."
arch=('x86_64' 'i686')
url="http://www.linux-games.com/penguin-command/"
@@ -21,4 +21,8 @@ package() {
cd $pkgname-$pkgver
./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
make DESTDIR="$pkgdir/" install
+
+ # Install a desktop entry
+ install -Dm644 data/gfx/20explo.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 ../${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}