summaryrefslogtreecommitdiff
path: root/pcr/profile-sync-daemon/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-01-02 03:36:47 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-01-02 03:36:47 -0500
commitca026b287990ffbf3a35e09ae447bea33243417a (patch)
treef72e9b93a035496d51e9f9bd124f1a7fe0d13bd0 /pcr/profile-sync-daemon/PKGBUILD
parentffee505fbe7ae77dc01e5c7601ec353ff8932f4e (diff)
profile-sync-daemon: add new package to [pcr]
Diffstat (limited to 'pcr/profile-sync-daemon/PKGBUILD')
-rw-r--r--pcr/profile-sync-daemon/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/pcr/profile-sync-daemon/PKGBUILD b/pcr/profile-sync-daemon/PKGBUILD
new file mode 100644
index 000000000..c1583c241
--- /dev/null
+++ b/pcr/profile-sync-daemon/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer (Arch): graysky <graysky AT archlinux DOT us>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+
+pkgname='profile-sync-daemon'
+pkgver=6.31
+pkgrel=1.parabola1
+pkgdesc='Syncs browser profiles to tmpfs reducing SSD/HDD calls and speeding-up browsers.'
+arch=('any')
+url='https://github.com/graysky2/profile-sync-daemon'
+license=('MIT')
+depends=('procps-ng' 'rsync' 'systemd' 'findutils')
+conflicts=('goanysync' 'go-anysync-git' 'iceweasel-sync'
+'tmpfs-store' 'tmpfs-sync' 'user-profile-sync-daemon')
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+install=psd.install
+sha256sums=('3aa6f83ad5cb47653d486124233d6af7cf79e58bd1e57a4bcd34029012be9a13')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -f "$pkgdir/usr/share/man/man1/psd-overlay-helper.1.gz"
+}