summaryrefslogtreecommitdiff
path: root/pcr/python-pyspf/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-15 08:39:30 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-15 08:39:30 +0100
commit60d6447e482f4645bc11dcea0cbe5d93280f9f6c (patch)
tree90db03f316db2a2521410de50e1aa12d3470713f /pcr/python-pyspf/PKGBUILD
parent81e1c3af63967232c89d4b706f713abecf3520d2 (diff)
pcr/python-pyspf: re-added split package for python2-pyspf
Diffstat (limited to 'pcr/python-pyspf/PKGBUILD')
-rw-r--r--pcr/python-pyspf/PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/pcr/python-pyspf/PKGBUILD b/pcr/python-pyspf/PKGBUILD
index 4ed8be779..8048baa29 100644
--- a/pcr/python-pyspf/PKGBUILD
+++ b/pcr/python-pyspf/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor (AUR): Samed Beyribey <ras0ir@eventualis.org>
_pkgname=pyspf
-pkgname=python-$_pkgname
+pkgname=(python-pyspf python2-pyspf)
_basever=2.0.12
_patchver=t
_pkgver=${_basever}${_patchver}
@@ -14,15 +14,22 @@ license=('PSF')
source=("https://pypi.python.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$_pkgver.tar.gz")
md5sums=('c83143ad79074bf8c80235748a8a698f')
-pkgrel=2
+pkgrel=3
arch=('any')
-depends=('python-py3dns')
-makedepends=('python-setuptools')
-optdepends=('python-authres: Return RFC 5451 Authentication Results headers')
-conflicts=(python2-pyspf)
+makedepends=('python' 'python2')
-package() {
- cd "$srcdir/$_pkgname-${_basever}"
+package_python-pyspf() {
+ depends=('python python-py3dns')
+ optdepends=('python-authres: Return RFC 5451 Authentication Results headers')
+ cd "$srcdir/$_pkgname-${_basever}"
python setup.py install --root="$pkgdir" --optimize=1
}
+
+package_python2-pyspf() {
+ depends=('python2 python2-pydns python2-ipaddr')
+ optdepends=('python2-authres: Return RFC 5451 Authentication Results headers')
+
+ cd "$srcdir/$_pkgname-${_basever}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}