summaryrefslogtreecommitdiff
path: root/pcr/pythonqt/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-09 19:21:01 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-09 19:21:01 +0100
commit7575082fa3730c5ba531443de910555150038f99 (patch)
treef6422d255cec782bfd2d666be381823b062c6157 /pcr/pythonqt/PKGBUILD
parent6231995e0cd6245e34a8da5e54c7d282e7534073 (diff)
pcr/pythonqt: rebuilt
Diffstat (limited to 'pcr/pythonqt/PKGBUILD')
-rw-r--r--pcr/pythonqt/PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/pcr/pythonqt/PKGBUILD b/pcr/pythonqt/PKGBUILD
index c123198ba..210d99b09 100644
--- a/pcr/pythonqt/PKGBUILD
+++ b/pcr/pythonqt/PKGBUILD
@@ -1,20 +1,20 @@
+# Maintainer (AUR): Alfredo Ramos <alfredo dot ramos at yandex dot com>
+# Contributor (AUR): Chris <christopher.r.mullins g-mail>
+# Contributor (AUR): Ainola
+# Contributor (AUR): speps
# Maintainer: David P. <megver83@parabola.nu>
-# Contributor: Alfredo Ramos <alfredo dot ramos at yandex dot com>
-# Contributor: Chris <christopher.r.mullins g-mail>
-# Contributor: Ainola
-# Contributor: speps
pkgname=pythonqt
pkgver=3.2
-pkgrel=3
+pkgrel=6
pkgdesc='A dynamic Python binding for Qt applications'
arch=('i686' 'x86_64')
url='http://pythonqt.sourceforge.net/'
license=('LGPL2.1')
-depends=('python' 'qt5-multimedia' 'qt5-svg' 'qt5-webkit' 'qt5-declarative')
+depends=('python' 'qt5-multimedia' 'qt5-svg' 'qt5-webkit' 'qt5-declarative' 'qt5-xmlpatterns')
makedepends=('git' 'qt5-tools')
-conflicts=('qt5-python27-git')
+conflicts=("${pkgname}-svn" "${pkgname}-for-screencloud" 'qt5-python27-git')
replaces=("${pkgname}-qt5")
source=(
@@ -22,12 +22,14 @@ source=(
'fix_python_version.patch'
'pkgconfig_file.prf'
'create_pkgconfig_file.patch'
+ 'faster_build.patch'
)
sha512sums=(
'1ee0f50f5035568b38e945108f5496ba64355c6357c1ea8dfc17ad90fa360540769f94e0b3e0e398176e8a21c8afe139607f0b5a2e82c63f1cbd40201a25e0f0'
'9747898842f60bdfc5c38a54f7516a46b46279c57cbfa6c7f4796aa1ca5771ebb121f07fe4d09d23c60c92530750ee265808484f3e07aaae72065ed51c3896c7'
'a146b46d4fb7162dc4290c662971742a4f85e11b2f5f9d71b4cd52f500ed7f0c3c1cf9034ead2e91f3c4e133446838fa530b3e13d3618617c695f2a433fdbb23'
'9386ec26b3a59de492a9d8c31ca6c4f9e220510070a6d5c0a063618e3f6e7c4db611b27f6b46c028b5613e70453db67c060533e6940d72ff9ea623d80c2f99f9'
+ '3c560169a0c10eeea21c3f6d078220caea70886d0203ef6dee1157afdd0bc1c7198cc65c6f5b2b5f4f61e416fa52330e75f282534402c8e00b2fe0829f17ce2a'
)
prepare() {
@@ -43,6 +45,9 @@ prepare() {
# PythonQt pkg-config file (*.pc)
cp ../pkgconfig_file.prf build/
patch -Np1 < ../create_pkgconfig_file.patch
+
+ # Do not build tests nor examples
+ patch -Np1 < ../faster_build.patch
}
build() {