summaryrefslogtreecommitdiff
path: root/pcr/textext/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-21 10:31:19 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-21 10:48:56 +0100
commit7b9255e28c6303f97c980e9d159c1b1193999303 (patch)
treebefa3f4411002a7722a67719e1ac1873056b96a3 /pcr/textext/PKGBUILD
parent8598c56ce109941c7bc28bd1c68db2c6c22253ab (diff)
pcr/textext: updated to 0.9.1
Diffstat (limited to 'pcr/textext/PKGBUILD')
-rw-r--r--pcr/textext/PKGBUILD51
1 files changed, 33 insertions, 18 deletions
diff --git a/pcr/textext/PKGBUILD b/pcr/textext/PKGBUILD
index 92dbc487d..924ae1db3 100644
--- a/pcr/textext/PKGBUILD
+++ b/pcr/textext/PKGBUILD
@@ -1,23 +1,38 @@
-# Contributor (Arch): Joel Schaerer <joel.schaerer@laposte.net>
-# Maintainer (Arch): Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor (AUR): Joel Schaerer <joel.schaerer@laposte.net>
+# Maintainer (AUR): Stefan Husmann <stefan-husmann@t-online.de>
pkgname=textext
-pkgver=0.4.4
-pkgrel=3.1
+_pkgname=TexText
+pkgver=0.9.1
+pkgrel=4
pkgdesc="An inkscape extension which lets you add LaTeX equations to your drawings"
-arch=('i686' 'x86_64')
+arch=('any')
license=('BSD3')
-url="http://pav.iki.fi/software/textext/"
-depends=('inkscape' 'texlive-core' 'python2-lxml' 'pdf2svg')
-source=(http://pav.iki.fi/software/textext/$pkgname-$pkgver.tar.gz LICENSE.txt)
-md5sums=('5dbb18bf762565196f8ac1f68f8607e3'
- '91da7de463147c1c78b1c2e6f24da380')
+url="https://github.com/textext/textext"
+makedepends=('dos2unix')
+depends=('inkscape' 'texlive-core' 'python2')
+optdepends=('pdf2svg' 'pygtk' 'imagemagick6')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/textext/textext/releases/download/$pkgver/${_pkgname}-Linux-$pkgver.tar.gz"
+ "0001-Fix-Issue-111-Write-log-file-to-user-writable-dir.patch")
+
+sha256sums=('5c48544b4c51547792909ba89fd27432b58bfb26d9d9c3131ab65ec809d8198b'
+ '3fc97197fc55a7de3df3ec35955802156a9c9ead07f48fe821792c11f4dcfeab')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ dos2unix "$srcdir/$pkgname-$pkgver/extension/textext/__init__.py"
+ patch -l -p1 < "$srcdir/0001-Fix-Issue-111-Write-log-file-to-user-writable-dir.patch"
+}
+
package() {
- cd "$srcdir"
- install -Dm 644 LICENSE.txt \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
- install -Dm 755 textext.py \
- "${pkgdir}/usr/share/inkscape/extensions/textext.py"
- install -Dm 644 textext.inx \
- "${pkgdir}/usr/share/inkscape/extensions/textext.inx"
-} \ No newline at end of file
+ install -d "$pkgdir"/usr/share/inkscape/extensions
+ cd $pkgname-$pkgver/extension
+ cp -r $pkgname "$pkgdir"/usr/share/inkscape/extensions
+ install -m644 $pkgname.inx "$pkgdir"/usr/share/inkscape/extensions/
+ cd ..
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ install LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ cd "$pkgdir"/usr/share/inkscape/extensions/$pkgname
+ sed -i '1s+\#!/usr/bin/env python+\#!/usr/bin/env python2+' __init__.py typesetter.py
+}
+