summaryrefslogtreecommitdiff
path: root/pcr/thinkfan/PKGBUILD
diff options
context:
space:
mode:
authorMichał Masłowski <mtjm@mtjm.eu>2012-11-24 21:40:14 +0100
committerMichał Masłowski <mtjm@mtjm.eu>2012-11-24 21:40:14 +0100
commit76f02e67987546467ddcdb2d006533c9d8e791b5 (patch)
treed37f87dc372d83081faae5fc3e3e99c4d791ad18 /pcr/thinkfan/PKGBUILD
parent195c4578406bed02fbbb75e19abfb302d9a1f5fb (diff)
New thinkfan on pcr.
Diffstat (limited to 'pcr/thinkfan/PKGBUILD')
-rw-r--r--pcr/thinkfan/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/pcr/thinkfan/PKGBUILD b/pcr/thinkfan/PKGBUILD
new file mode 100644
index 000000000..18a97754f
--- /dev/null
+++ b/pcr/thinkfan/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
+
+pkgname=thinkfan
+pkgver=0.8.1
+pkgrel=3
+pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL')
+source=(http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ "thinkfan" "thinkfan.service")
+url="http://thinkfan.sourceforge.net/"
+md5sums=('aaa6c88bab3b43756ac5a1638622828c'
+ '16fc3a83a1468e3ccaeba67e14ab2177'
+ '7639b82035fcee712753e05de6b0601d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+ install -D -m755 ${pkgname} ${pkgdir}/usr/sbin/${pkgname}
+ install -D -m755 ${srcdir}/${pkgname} ${pkgdir}/etc/rc.d/${pkgname}
+ install -D -m644 README ${pkgdir}/usr/share/doc/${pkgname}/README
+ install -D -m644 ${srcdir}/thinkfan.service ${pkgdir}/usr/lib/systemd/system/thinkfan.service
+ cp -r examples ${pkgdir}/usr/share/doc/${pkgname}/
+}
+
+# vim:set ts=2 sw=2 noet: